"Open in New Mail Window" missing from folder context menu

VERIFIED FIXED in Thunderbird2.0

Status

Thunderbird
Mail Window Front End
--
major
VERIFIED FIXED
12 years ago
11 years ago

People

(Reporter: Calum Mackay, Assigned: Scott MacGregor)

Tracking

({regression, verified1.8.1})

Trunk
Thunderbird2.0
regression, verified1.8.1

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
Linux/x86, local builds from CVS. Multiple IMAP servers.

Sometime between 20060127 and 20060215, my locally built Thunderbird seems to have lost the "Open in New Mail Window" function from a folder's context menu.

I like to have multiple tb windows open, each with a different folder in view, and I can't quite see how to do it, using the current menus. I see no option to do this anywhere. No doubt I'm missing something obvious... :(

I can't narrow down the regression further, since a Debian libxft bug broke my builds for a few weeks.
(Assignee)

Comment 1

12 years ago
you can double click the folder.
this was part of some menu context cleanup in the folder pane. 
(Reporter)

Comment 2

12 years ago
Thanks; unfortunately, double-clicking on a folder doesn't do anything for me, with my build of today 20060217.

I'd also like to argue that this isn't ideal, for two reasons:

o Users have no way of finding out that this is how to do it. Except, perhaps by analogy with double-clicking on a msg. But then, how do they find out about that?

o Double-clicking on a folder loads that folder in the current window; which loses context. The old context menu method did not disturb the current window's selected folder.
(Reporter)

Comment 3

12 years ago
re comment 2: nothing in JS console when I double-click, either.

Comment 4

12 years ago
Confirmed with my build also that it's not working anymore. Neither is double clicking the folder.

/usr/local/thunderbird/thunderbird --version
 Thunderbird 1.6a1, Copyright (c) 2005-2006 mozilla.org

Comment 5

12 years ago
I see this with TB 1.5-0215, Win2K, so it's not just trunk and not just Linux.

Scott, double-clicking a folder acts to expand/collapse if the folder has subs.  Altho multiple windows isn't something I use, and I prefer a more compact context menu, obviously some people do use this and it sucks to just take it away.  How about sticking it in the main menu -- maybe in the otherwise worthless "Go" menu?
Keywords: regression
OS: Linux → All
(Reporter)

Comment 6

12 years ago
I'd like to request adding the item back to the folder context menu. I use a new window for every folder I visit, to avoid disturbing existing folder views, and it was so easy before this change.

I note that the per-message context menu is enormous by comparision, so I don't see one extra item making the difference here (of course, that could be argued for every item :)

Comment 7

12 years ago
*** Bug 328404 has been marked as a duplicate of this bug. ***

Comment 8

12 years ago
(In reply to comment #1)
> you can double click the folder.
> this was part of some menu context cleanup in the folder pane. 

bug#?

Please restore functionality. 

Comment 9

12 years ago
seeing this also in the mac version of TB 1.6a2 20060225 ... can the hardware type be changed to "All"?
(Reporter)

Updated

12 years ago
Hardware: PC → All
(Reporter)

Comment 10

12 years ago
Scott, do we need some blocking flags here? Seems like a serious regression.

Sigh; it's hampering my general QA testing efforts, as I'm now stuck on 20060127. the combination of this bug, and whichever bug covers the fact that double-clicking doesn't open a new window, means it would appear that there is now no way to have more than one Thunderbird window open at a time, which renders it useless for me, at least.

Unlike Firefox, running the TB cmdline startup script does not open a new window if the app is already running.

Comment 11

12 years ago
hack workaround:
1. "search messages" for any message in the folder you want to open
2. select a message in search results
3. click "open message folder"

Totally unsatisfactory of course.  Need the context menu back.
Flags: blocking-thunderbird2?
(Assignee)

Comment 12

12 years ago
Created attachment 216689 [details] [diff] [review]
add back Open

We can't have Calum not testing the latest nightlies for us.
(Assignee)

Comment 13

12 years ago
fixed on the trunk and 1.8.1 branch.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Flags: blocking-thunderbird2?
Keywords: fixed1.8.1
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird2.0
(Reporter)

Comment 14

12 years ago
marking verified; thanks much indeed Scott, appreciated.
Status: RESOLVED → VERIFIED

Comment 15

11 years ago
changing keyword to verified.    this is on version 2.0.0.0pre (20070402)
Keywords: fixed1.8.1 → verified1.8.1
You need to log in before you can comment on or make changes to this bug.