XForms Extension Causes Segmentation Fault In GNU/Linux

RESOLVED FIXED

Status

Core Graveyard
XForms
--
major
RESOLVED FIXED
12 years ago
a year ago

People

(Reporter: lightsolphoenix, Assigned: aaronr)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060209 Debian/1.5.dfsg+1.5.0.1-2 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060209 Debian/1.5.dfsg+1.5.0.1-2 Firefox/1.5.0.1

Since I upgraded to Firefox 1.5, I've been noticing that Firefox doesn't always load right away.  Sometimes, I have to just click over and over and over again on the desktop shortcut (opening 10 or so windows) and hope that one of those windows actually makes it through.

The other day, I had to disable all my extensions (bug in one of them was causing the browser to act strangely), and I noticed the problem went away.  Previously, I had left on certain extensions while turning off others, and the problem had remained.  After some experimentation, I found that it was the Mozilla XForms extension that was causing the segmentation faults (oh, I confirmed that's what it was by trying to run Firefox from the command line - it kept giving me "Segmentation Fault" as a result).

Reproducible: Sometimes

Steps to Reproduce:

Comment 1

12 years ago
(In reply to comment #0)
> Since I upgraded to Firefox 1.5, I've been noticing that Firefox doesn't always
> load right away.  Sometimes, I have to just click over and over and over again
> on the desktop shortcut (opening 10 or so windows) and hope that one of those
> windows actually makes it through.
> 
> The other day, I had to disable all my extensions (bug in one of them was
> causing the browser to act strangely), and I noticed the problem went away. 
> Previously, I had left on certain extensions while turning off others, and the
> problem had remained.  After some experimentation, I found that it was the
> Mozilla XForms extension that was causing the segmentation faults (oh, I
> confirmed that's what it was by trying to run Firefox from the command line -
> it kept giving me "Segmentation Fault" as a result).

Yes, unfortunately the xforms.xpi that was released was built with a wrong host config :(, so it segfaults. We've updated the xforms.xpi, so please install the one we refer to on:
http://www.mozilla.org/projects/xforms/#HowDownload
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.