HTML file input type doesn't allow pasting path in text field anymore

VERIFIED WONTFIX

Status

Camino Graveyard
HTML Form Controls
VERIFIED WONTFIX
12 years ago
12 years ago

People

(Reporter: Ruurd Koons, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Trunk
PowerPC
Mac OS X

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060216 Camino/1.0+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060216 Camino/1.0+

For each file upload element, it seems to be impossible to enter a file manually anymore.  Instead, when clicking on the text area, the browse window pops up.  This is quite annoying for long locations that come from for instance the Terminal.app, that I used to be able to just copy over.  Now the input field doesn't allow me to paste in it, and I have to go through the whole file browser.  

Although this will be a feature for many, I consider it a bug.  At least it slows me down a lot, and I hope this feature is removed again.

Reproducible: Always

Steps to Reproduce:
1. go to a page with a file upload thing, for instance a bugzilla bug, add attachment page
2. copy an absolute location from the terminal (pwd -> select -> copy)
3. try to select the test field of the file upload thing and paste

Actual Results:  
a system dong is heard, and the file browser appears, trying to help to locate the file

Expected Results:  
the text field should just get focus and allow me to paste my absolute file URI in it, so I don't have to traverse 20+ paths in the file browser

At least I would like to have the ability to disable this behaviour somehow.  I don't care if it is in the prefs.js file.  I frequently upload patches through this method, and that seriously has become a great pain to do now.
Works in 1.0, so must be trunk-only.  I think I saw some discussion that this change was going to happen for security purposes, and that since on most platforms you could paste into the filepicker (cmd-shift-G on the Mac) it was an acceptable trade-off.

Someone should check to see whether this really happened already or if this was an unrelated regression (and either way, a regression window would be useful).
Version: unspecified → Trunk

Comment 2

12 years ago
> I think I saw some discussion that this
> change was going to happen for security purposes, [...]

Bug 258875, should have been like this for the trunk for 5 months.
So this is WONTFIX if it's actually been implemented.
WONTFIX per bug Bug 258875.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WONTFIX
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.