Embed tag fails to instantiate plugin

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: JoeS1, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050924 Firefox/1.0.7 (stipe s8v4)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060218 SeaMonkey/1.5a

With plugins enabled in Mail/News and a valid enabled plugin installed the plugin is not called via the embed tag.

Reproducible: Always

Steps to Reproduce:
1.Insert the following into an html email
<embed src="http://wtv-zone.com/REMEMBERTHEN/midis3/stayinalive.mid"
 autostart="true" hidden="false" loop="true" save="True" height="60"
 width="144">
2.Send it to yourself, or view it as unsent.
3.

Actual Results:  
The embed tag seems to be completely ignored.

Expected Results:  
Call the Crescendo plugin and play the midi file

This works as expected in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051228 SeaMonkey/1.5
Does not work in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060211 SeaMonkey/1.5a
Thats as close as I can get the regression range.
I'm using zip builds, with identical prefs and plugins.
(Reporter)

Comment 1

13 years ago
Created attachment 212385 [details]
The zipped crescendo plugin for midi's

Comment 2

13 years ago
Do you get a remote content warning?
(Reporter)

Comment 3

13 years ago
(In reply to comment #2)
> Do you get a remote content warning?
> 
No warning Frank
The tag also seems to be ignored if inline content is used via JS document.write "embed" as well.
If the iframe tag is used in the above examples, the plugin is called as expected.

Updated

13 years ago
Version: unspecified → Trunk
(Reporter)

Comment 4

13 years ago
Took the following actions:
Created a new profile..No help
Downloaded Thunderbird Trunk..The embed tag invokes the plugin expected.
So it would seem this is not a 'core' problem.
Also Linux users do not seem to be seeing this bug.
(Reporter)

Comment 5

13 years ago
Attempting to narrow the regression range.
20060124 works Ok 20060125, and 20060126 are unusable builds.
20060128 shows the regression.
(Reporter)

Comment 6

13 years ago
This problem persists in
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060314 SeaMonkey/1.5a
(Reporter)

Comment 7

12 years ago
Some additional info on the embed tag and current trunk seamonkey.
The problem does not seem to be limited to plugin instantiation, but to a larger problem with the embed tag in Mailnews. The tag seems to be ignored.
Paste the following examples into an html mail composition, then save and view it or send it to yourself.
<embed src="http://img253.imageshack.us/img253/37/tb150pw.jpg">
The content does not render.
<iframe src="http://img253.imageshack.us/img253/37/tb150pw.jpg"></iframe>
The content is rendered as expected.
Please note that this has nothing to do with recent remote content changes made
recently in bug 357321 as I have the pref set to allow remote images, and this
is a symptom that has existed in seamonkey trunk for quite a while.
This is important for newsgroup users who traditionally use this feature.

Comment 8

12 years ago
Maybe Bug 294307 changed something there (it's in the regression range).

Comment 9

11 years ago
Joe, do you see bug 208850 and would it be related to this?
(Reporter)

Comment 10

11 years ago
(In reply to comment #9)
> Joe, do you see bug 208850 and would it be related to this?
> 
Never saw the symptoms of bug 208850

After further testing with:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a9pre) Gecko/2007092210 SeaMonkey/2.0a1pre
The embed tag seems to be working normally in mailnews
Since this is the main developemnt branch for seamonkey now marking WFM

Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.