Closed Bug 327833 Opened 14 years ago Closed 13 years ago

In <inspector.xul>, "Failed to load overlay from chrome://browser/content/baseMenuOverlay.xul"

Categories

(Other Applications :: DOM Inspector, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jfm, Assigned: sdwilsh)

References

Details

Attachments

(1 file, 2 obsolete files)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/417.9 (KHTML, like Gecko) Safari/417.8
Build Identifier: seamonkey-1.0 built_from_src

When opening Tools/Web/DOM Inspector :
Warning: Failed to load overlay from chrome://browser/content/baseMenuOverlay.xul.
Source File: chrome://inspector/content/inspector.xul
Line: 0

Indeed:
/sw/bld/seamonkey-1.0-1/mozilla# grep -rI baseMenuOverlay *                                  
find . -name 'baseMenuOverlay.*'
extensions/inspector/resources/content/inspector.xul:<?xul-overlay href="chrome://browser/content/baseMenuOverlay.xul"?>
/sw/bld/seamonkey-1.0-1/mozilla# find . -name 'baseMenuOverlay.*'
/sw/bld/seamonkey-1.0-1/mozilla# 
Contrasting with:
http://lxr.mozilla.org/mozilla1.8.0/search?string=baseMenuOverlay :
/browser/base/content/baseMenuOverlay.xul, line 43 -- <!ENTITY % baseMenuOverlayDTD SYSTEM "chrome://browser/locale/baseMenuOverlay.dtd">
/browser/base/content/baseMenuOverlay.xul, line 44 -- %baseMenuOverlayDTD;
/browser/base/content/baseMenuOverlay.xul, line 46 -- <overlay id="baseMenuOverlay"
/browser/base/content/browser-sets.inc, line 339 -- # Used by baseMenuOverlay
/browser/base/content/browser.xul, line 50 -- <?xul-overlay href="chrome://browser/content/baseMenuOverlay.xul"?>
/browser/base/content/macBrowserOverlay.xul, line 51 -- <?xul-overlay href="chrome://browser/content/baseMenuOverlay.xul"?>
/browser/base/content/viewSourceOverlay.xul, line 42 -- <?xul-overlay href="chrome://browser/content/baseMenuOverlay.xul"?>
/browser/components/bookmarks/content/bookmarksManager.xul, line 47 -- <?xul-overlay href="chrome://browser/content/baseMenuOverlay.xul"?>
/browser/locales/jar.mn, line 8 -- locale/browser/baseMenuOverlay.dtd (%chrome/browser/baseMenuOverlay.dtd)
This is with seamonkey-1.0 straight from mozilla's site:
/sw/bld/seamonkey-1.0-1/mozilla# md5sum /sw/src/seamonkey-1.0.source.tar.bz2 
e4f2edc5b2248d090303c70f5b28f210  /sw/src/seamonkey-1.0.source.tar.bz2


Reproducible: Always

Steps to Reproduce:
1.Build probably irrelevant, if not :
2.ConfigureParams: --enable-xft --disable-freetype2 --enable-calendar
--enable-optimize="-O3 -fstrict-aliasing" --disable-debug
--enable-application=suite --enable-macos-target=10.4 --enable-prebinding
--enable-default-toolkit=gtk2 --with-pthreads
--with-default-mozilla-five-home=%p/lib/%N --mandir=%p/share/man --enable-strip
--enable-extensions=all --enable-image-decoders=all --enable-ldap-experimental
--enable-xpctools --enable-necko-protocols=all --enable-efence
--enable-native-uconv --enable-ctl --enable-xinerama --with-system-mng
--with-system-jpeg --with-system-png --with-system-zlib --enable-postscript
--enable-ipv6 --enable-tests --with-x --enable-canvas --with-qtdir=%p
--enable-pango --enable-svg --enable-update-packaging --enable-storage
--enable-system-cairo --enable-profilesharing
3.For identical setup, grab my .info and .patch files from my experimental
dir:
http://cvs.sourceforge.net/viewcvs.py/fink/experimental/jfmertens/crypto/finkinfo/
and 'fink install seamonkey'


Actual Results:  
cf supra

Expected Results:  
-
Bug 295711 added that firefox-overlay in inspector.xul. SeaMonkey doesn't have it - that's why you see the error msg. This is known (https://bugzilla.mozilla.org/show_bug.cgi?id=295711#c23), but was never filed.
Status: UNCONFIRMED → NEW
Depends on: 295711
Ever confirmed: true
OS: MacOS X → All
Hardware: Macintosh → All
Assignee: dom-inspector → benjamin
Assignee: benjamin → nobody
[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.1) Gecko/20061011 SeaMonkey/1.1b] (nightly) (W98SE)

Bug still there.
Blocks: 295711
No longer depends on: 295711
Summary: "Failed to load overlay from chrome://browser/content/baseMenuOverlay.xul" → In <inspector.xul>, "Failed to load overlay from chrome://browser/content/baseMenuOverlay.xul"
Attached patch v1.0 (obsolete) — Splinter Review
Having Alex test this before I request for review.  This also gets rid of the navigator errors that occur in Firefox.

This /shouldn't/ break anything else, but the more people to test this, the merrier (I only build browser).
Assignee: nobody → comrade693+bmo
Status: NEW → ASSIGNED
Attached patch v1.1 (obsolete) — Splinter Review
Silly me, Seamonkey doesn't support chrome.manifest, so I can only fix the issue that this bug reported.

This doesn't seem to break browser.
Attachment #245873 - Attachment is obsolete: true
Attachment #245876 - Flags: superreview?(neil)
Attachment #245876 - Flags: review?(timeless)
Attachment #245876 - Flags: superreview?(neil) → superreview+
Attachment #245876 - Flags: review?(timeless) → review+
Whiteboard: [checkin needed]
v1.1 checked in by smaug.  Reporter/one of you who confirmed this, can you verify in the next build please?
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Whiteboard: [checkin needed]
Syntax is wrong for the overlay - causing problems (I'm unsure how these problems aren't showing up on my build).

New patch shortly.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20061121 Minefield/3.0a1 ID:2006112121 [cairo]

this has caused Firefox not to startup anymore.
(In reply to comment #7)
> this has caused Firefox not to startup anymore.

It should work with a new profile, right? I think it only affects profiles that were used when the broken patch was checked in.
(In reply to comment #8)
> (In reply to comment #7)
> > this has caused Firefox not to startup anymore.
> 
> It should work with a new profile, right? 

apparently not, same problem with clean new profile


(In reply to comment #9)
> (In reply to comment #8)
> > (In reply to comment #7)
> > > this has caused Firefox not to startup anymore.
> > 
> > It should work with a new profile, right? 
> 
> apparently not, same problem with clean new profile
> 
The startup problem when DOMi is enabled seems to have gone away with a clobber.
It's working okay for me in the most recent nightly, and in subsequent hourlies.
(In reply to comment #7)
> Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20061121
> Minefield/3.0a1 ID:2006112121 [cairo]
> 
> this has caused Firefox not to startup anymore.

Do you mean after the patch was backed out?
(In reply to comment #12)
> (In reply to comment #7)
> > Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20061121
> > Minefield/3.0a1 ID:2006112121 [cairo]
> > 
> > this has caused Firefox not to startup anymore.
> 
> Do you mean after the patch was backed out?
> 
Yes, there were startup probs (high cpu and memory, never came up all the way) after the patch was backed out by timeless...which persisted until the clobber by the nightly,
Attached patch v1.2Splinter Review
Looks like the change we were talking about on irc last night would have worked timeless - I just needed to do a new clean build instead of just remaking extensions/inspector.

This uses the right syntax, and I don't have any strange issues like I used to have.
Attachment #245876 - Attachment is obsolete: true
Attachment #246311 - Flags: superreview?(neil)
Attachment #246311 - Flags: review?(timeless)
Attachment #246311 - Flags: superreview?(neil) → superreview+
Attachment #246311 - Flags: review?(timeless) → review+
Whiteboard: [checkin needed]
Status: REOPENED → RESOLVED
Closed: 13 years ago13 years ago
Resolution: --- → FIXED
Whiteboard: [checkin needed]
[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.1.1pre) Gecko/20061203 SeaMonkey/1.1] (nightly) (W98SE)

Would this patch apply to 1.8 branch ?
(In reply to comment #15)
> [Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.1.1pre) Gecko/20061203
> SeaMonkey/1.1] (nightly) (W98SE)
> 
> Would this patch apply to 1.8 branch ?

It might, but I don't have 1.8 branch checked out.
(In reply to comment #16)
> > Would this patch apply to 1.8 branch ?
> 
> It might, but I don't have 1.8 branch checked out.

Neil, could you advice/help ? Thanks.
Try installing the trunk .xpi into a branch build?
[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.1.1) Gecko/20061206 SeaMonkey/1.1] (nightly) (W98SE)

I tried replacing the inside inspector.jar:
DomI starts, but there are other "errors"...
(Trunk and branch seem quite different.)

I removed the line from the initial inspector.xul,
and don't get the warning, as expected.

What I can't test, and what I was (mainly) asking about, is the jar.mn (syntax) change.
(In reply to comment #19)
> What I can't test, and what I was (mainly) asking about, is the jar.mn (syntax)
> change.

If you are using Seamonkey, you don't need to worry about the jar.mn change.
Comment on attachment 246311 [details] [diff] [review]
v1.2


'approval-seamonkey1.1=?':
(for the inspector.xul part only)
Trivial U.I. code cleanup, no risk.
(applies cleanly to v1.10.4.1)
Attachment #246311 - Flags: approval-seamonkey1.1?
Comment on attachment 246311 [details] [diff] [review]
v1.2

This is inspector code and effectively changes code that is for Firefox support, not SeaMonkey support, so SeaMonkey approval does not apply. Please ask for a1.8.1.2 or whatever inspector needs these days.
Attachment #246311 - Flags: approval-seamonkey1.1?
QA Contact: timeless → dom-inspector
You need to log in before you can comment on or make changes to this bug.