Thunderbird (1.5 - 20051201) ocasionally crashes when I attempt to view a large mail

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
--
critical
RESOLVED WORKSFORME
13 years ago
5 years ago

People

(Reporter: Mihai Dontu, Unassigned)

Tracking

({crash})

1.8 Branch
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060124 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060124 Firefox/1.5.0.1

Sometimes, when I try to view a mail in a separate window (double click on it), Thunderbird crashes. This time I was able to reproduce it quite easy on a Linux-kernel-daily-digest (which is quite big).

Here's a stack dump (if it helps):

#0  0x40a1b1b1 in kill () from /lib/libc.so.6
#1  0x401d89c1 in pthread_kill () from /lib/libpthread.so.0
#2  0x401d8ccb in raise () from /lib/libpthread.so.0
#3  0x0808363a in nsTHashtable<nsBaseHashtableET<nsDepCharHashKey, nsAutoPtr<nsINIParser::INIValue> > >::~nsTHashtable ()
#4  0x401dbbe5 in pthread_barrierattr_setpshared () from /lib/libpthread.so.0
#5  <signal handler called>
#6  0x20202020 in ?? ()
#7  0x40067824 in js_GetSlotThreadSafe () from /usr/local/thunderbird/libmozjs.so
#8  0x40057558 in js_ComputeThis () from /usr/local/thunderbird/libmozjs.so
#9  0x40057c0f in js_Invoke () from /usr/local/thunderbird/libmozjs.so
#10 0x40062b17 in js_Interpret () from /usr/local/thunderbird/libmozjs.so
#11 0x40057ed0 in js_Invoke () from /usr/local/thunderbird/libmozjs.so
#12 0x080a830b in nsTHashtable<nsBaseHashtableET<nsDepCharHashKey, nsAutoPtr<nsINIParser::INIValue> > >::~nsTHashtable ()
#13 0x080a5bab in nsTHashtable<nsBaseHashtableET<nsDepCharHashKey, nsAutoPtr<nsINIParser::INIValue> > >::~nsTHashtable ()
#14 0x4015c6e3 in XPTC_InvokeByIndex () from /usr/local/thunderbird/libxpcom_core.so
#15 0x083dcbbe in nsReadingIterator<unsigned short>::advance ()
#16 0x083dd05a in nsReadingIterator<unsigned short>::advance ()
#17 0x08465785 in nsReadingIterator<unsigned short>::advance ()
#18 0x0824b384 in XmlInitUnknownEncodingNS ()
#19 0x08568b11 in nsXPTCVariant::Init ()
#20 0x085412b0 in nsXPTCVariant::Init ()
#21 0x08568878 in nsXPTCVariant::Init ()
#22 0x0854947e in nsXPTCVariant::Init ()
#23 0x085489c8 in nsXPTCVariant::Init ()
#24 0x08548897 in nsXPTCVariant::Init ()
#25 0x085485b8 in nsXPTCVariant::Init ()
#26 0x080ed924 in nsTHashtable<nsBaseHashtableET<nsDepCharHashKey, nsAutoPtr<nsINIParser::INIValue> > >::~nsTHashtable ()
#27 0x08263fef in XmlInitUnknownEncodingNS ()
#28 0x08263cf0 in XmlInitUnknownEncodingNS ()
#29 0x40142b37 in PL_HandleEvent () from /usr/local/thunderbird/libxpcom_core.so
#30 0x40142a64 in PL_ProcessPendingEvents () from /usr/local/thunderbird/libxpcom_core.so
#31 0x40144659 in nsEventQueueImpl::CheckForDeactivation () from /usr/local/thunderbird/libxpcom_core.so
#32 0x0821ff95 in XmlInitUnknownEncodingNS ()
#33 0x406484bf in g_vasprintf () from /usr/lib/libglib-2.0.so.0
#34 0x40622c02 in g_main_depth () from /usr/lib/libglib-2.0.so.0
#35 0x40623c78 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#36 0x40623fb0 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#37 0x40624553 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#38 0x40327beb in gtk_main () from /usr/local/lib/libgtk-x11-2.0.so.0
#39 0x082202d8 in XmlInitUnknownEncodingNS ()
#40 0x086bdc07 in nsXPTCVariant::Init ()
#41 0x0807cd0e in ?? ()
#42 0x08d1bb38 in ?? ()
#43 0x08a0ddc8 in _IO_stdin_used ()
#44 0x00000000 in ?? ()
#45 0x00000000 in ?? ()
#46 0x00000000 in ?? ()
#47 0x00000000 in ?? ()
#48 0x00000000 in ?? ()
#49 0x00000000 in ?? ()
#50 0x00000000 in ?? ()
#51 0x00000000 in ?? ()
#52 0x00000000 in ?? ()
#53 0x00000000 in ?? ()
#54 0x00000000 in ?? ()
#55 0x00000001 in ?? ()
#56 0x08a0f160 in nsIFactory::GetIID()::iid ()
#57 0xbfc766f8 in ?? ()
#58 0x08a0f160 in nsIFactory::GetIID()::iid ()
#59 0xbfc766f8 in ?? ()
#60 0xbfc76700 in ?? ()
#61 0x00000000 in ?? ()
#62 0x08a0f0c0 in nsIFactory::GetIID()::iid ()
#63 0xbfc766f4 in ?? ()
---Type <return> to continue, or q <return> to quit---
#64 0x08a0f0c0 in nsIFactory::GetIID()::iid ()
#65 0xbfc766f4 in ?? ()
#66 0xbfc7685c in ?? ()
#67 0x00000000 in ?? ()
#68 0x00000000 in ?? ()
#69 0x00000000 in ?? ()
#70 0x0000000d in ?? ()
#71 0x00000000 in ?? ()
#72 0x00000001 in ?? ()
#73 0x08c1db00 in ?? ()
#74 0x08f4b790 in ?? ()
#75 0x00000000 in ?? ()
#76 0x67000000 in ?? ()
#77 0x40932464 in ?? ()
#78 0x08e2d3b8 in ?? ()
#79 0x40007c01 in _dl_lookup_versioned_symbol_skip () from /lib/ld-linux.so.2
#80 0x080789d4 in ?? ()
#81 0x00000001 in ?? ()
#82 0xbfc76964 in ?? ()
#83 0x08a0de40 in _IO_stdin_used ()
#84 0x0806f4ca in _init ()
#85 0x40a07936 in __libc_start_main () from /lib/libc.so.6
#86 0x08078901 in ?? ()

This has not happened with previous versions.


Reproducible: Sometimes

Steps to Reproduce:
There isn't a "3 step" way to reproduce it since I don't know the conditions. I get a lot of big mails, still this is the only one on which it segfauls (althought it looks like it's abort()-ing), but I'm more than willing to do watherver tests you want me to with this particular mail (and probably an unstripped thunderbird.bin)
(Reporter)

Comment 1

13 years ago
I apologise, I forgot to specify my system information and the button for editing the bug is "hiding" from me :) So:

Slackware Linux 10.0
gcc 3.3.4
glibc 2.3.2
glib 1.2.10
gtk 2.6.9
Intel P4, HT

Comment 2

13 years ago
your object was gc'd.
Assignee: mscott → general
Component: General → JavaScript Engine
Keywords: crash
Product: Thunderbird → Core
QA Contact: general → general
Whiteboard: DUPEME
Version: unspecified → 1.8 Branch

Updated

13 years ago
Severity: normal → critical
(Reporter)

Comment 3

12 years ago
The bug appeares fixed in 1.5.2 (I have not reproduced it anymore).
I belive you (or me) could put this on "fixed".

Comment 4

12 years ago
Mihai, can you reproduce this with a 1.5.0.4 or 1.5.0.5 nightly build?
(Reporter)

Comment 5

12 years ago
(In reply to comment #4)
> Mihai, can you reproduce this with a 1.5.0.4 or 1.5.0.5 nightly build?
> 

- 1.5.0.4 no
- 1.5.0.5 still trying to get my hands on it

Comment 6

12 years ago
(In reply to comment #5)

> - 1.5.0.5 still trying to get my hands on it

<http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-mozilla1.8.0/>
(Reporter)

Comment 7

12 years ago
Good news. I was unable to reproduce the bug on 1.5.0.5.
It would seem that it's fixed.

Comment 8

12 years ago
Thanks, I'll mark this works for me for now. Be sure to download and install the official 1.5.0.5 builds when they are released!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.