Closed Bug 327912 Opened 14 years ago Closed 13 years ago

Clean up file menu and calendar context menu (Sunbird)

Categories

(Calendar :: Sunbird Only, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED
Sunbird 0.3

People

(Reporter: ssitter, Assigned: ssitter)

References

Details

(Whiteboard: [cal-ui-review+][l10n impact])

Attachments

(3 files, 3 obsolete files)

With adding new features to Sunbird like Import and Export recently the file menu and the calendar context menu got a little bit complex and inconsistent. Some commands are only offered from one of the menus or are labeled with different wording.

I would like to propose some changes with the following goals:
 * remove unnecessary commands
 * group related commands together
 * improve and unify wording

My first draft/proposal for the menus can be found at http://wiki.mozilla.org/User:Ssitter:SunbirdMenuRework
I'll start working on this.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Depends on: 332414
Assignee: nobody → ssitter
Status: ASSIGNED → NEW
I have updated http://wiki.mozilla.org/User:Ssitter:SunbirdMenuRework with the current proposal - in case someone wants to add a comment before I'm getting done with the patch.
Some comments from bug 330178 comment 9 still hold:
- There should be a 'rename' option in the calendar context menu
- Reload Calendars is out of place for a context menu, because it acts on more than just the selected item

Otherwise, the proposal looks good.
Hi,
here are my 2 cents

Proposal for File menu:
- There should be a separator between
  Export Calendar...
  &
  Publish Selection...
  
- 'Reload Remote Calendar' should be moved into the View Menu
- Do we need 'Close Window' in Sunbird?
  I think the answer is no, because it's not a MDI Application.
  Exiting an application via a 'Close Window' entry is somehow
  strange.
(In reply to comment #3)
At the moment I want to focus on cleaning up first. Adding new functionality can be done afterwards.
This rearranges the sunbird calendar context menu for improved usability (without adding/removing functionality).
Attachment #225746 - Flags: first-review?(jminta)
Attached patch part 2: sunbird file menu (obsolete) — Splinter Review
This rearranges the sunbird file menu for improved usability. Unused stuff is removed, Edit moved to Edit menu and new entries for export/publish calendar are added.
Attachment #225756 - Flags: first-review?(jminta)
Need mvl (or maybe dmose) to sign off on this proposal.
Whiteboard: [cal-ui-review needed]
Comment on attachment 225746 [details] [diff] [review]
part 1: sunbird calendar context menu

Requesting UI-review acc. to Comment #8
Attachment #225746 - Flags: second-review?(mvl)
Comment on attachment 225756 [details] [diff] [review]
part 2: sunbird file menu

Requesting UI-review acc. to Comment #8
Attachment #225756 - Flags: second-review?(mvl)
Resubmitting because previous version of patch is rotten.
Attachment #225746 - Attachment is obsolete: true
Attachment #230771 - Flags: second-review?(mvl)
Attachment #230771 - Flags: first-review?(jminta)
Attachment #225746 - Flags: second-review?(mvl)
Attachment #225746 - Flags: first-review?(jminta)
Attached patch part 2: sunbird file menu, v2 (obsolete) — Splinter Review
Resubmitting because previous version of patch is rotten.
Attachment #225756 - Attachment is obsolete: true
Attachment #230772 - Flags: second-review?(mvl)
Attachment #230772 - Flags: first-review?(jminta)
Attachment #225756 - Flags: second-review?(mvl)
Attachment #225756 - Flags: first-review?(jminta)
Comment on attachment 230771 [details] [diff] [review]
part 1: sunbird calendar context menu, v2

The 'import' item isn't very often used. And its not clear what it imports and into what. That implies that it's better to just leave it out of the context menu. ui-review=dmose,mvl (and using the second-review flag for that)
Attachment #230771 - Flags: second-review?(mvl) → second-review+
Comment on attachment 230771 [details] [diff] [review]
part 1: sunbird calendar context menu, v2

r=jminta
Attachment #230771 - Flags: first-review?(jminta) → first-review+
Updated patch according to Comment #13 (removed 'Import' from context menu) for checkin. Carry over r=jminta and ui-review=dmose,mvl flags.
Attachment #230941 - Flags: second-review+
Attachment #230941 - Flags: first-review+
Comment on attachment 230941 [details] [diff] [review]
part 1: sunbird calendar context menu, v3 [checked in]

checked in on trunk and branch
Attachment #230941 - Attachment description: part 1: sunbird calendar context menu, v3 → part 1: sunbird calendar context menu, v3 [checked in]
Comment on attachment 230772 [details] [diff] [review]
part 2: sunbird file menu, v2


-           <menuitem id="calendar-close"
-                     key="key_close"
-                     label="&calendar.menu.options.close;"
-                     accesskey="&calendar.menu.options.close.accesskey;"
-                     observes="close_calendar_command"/>
If you're going to remove this, you should also remove the <command> and the function.

One of the things I don't like about this is the publish_command and export_command become very vague.  I think we need to sit down and figure out which of those should be commands and which should just be oncommand handlers of specific elements.
Target Milestone: --- → Sunbird 0.3
Comment on attachment 230772 [details] [diff] [review]
part 2: sunbird file menu, v2

That patch is rotten again. Please decide on cal-ui-review and if this UI cleanup should be part of 0.3. In that case I might submitt a new patch before String Freeze.
Could you post a copy of the spec on the wiki page in this bug? (history of bugs is easier accessible then wiki history)
[http://wiki.mozilla.org/User:Ssitter:SunbirdMenuRework]

Current File Menu:

    ----------------------------------
    New Event...
    New Task...
    New Journal Item...
    New Calendar File...
    Open Calendar File...
    Edit Selection...
    Close Window
    ----------------------------------
    Subscribe to Remote Calendar...
    Reload Remote Calendars
    ----------------------------------
    Import...
    Export Selection...
    Mail Selection...
    Publish...
    ----------------------------------
    Page Setup...
    Print...
    ----------------------------------
    Quit
    ----------------------------------	

Proposal:

    ----------------------------------
    New Event...
    New Task...
    New Calendar...
    Open Calendar File...
    Subscribe to Remote Calendar...
    ----------------------------------
    Import...
    Export Selection...
    Export Calendar...
    ----------------------------------
    Publish Selection...
    Publish Calendar...
    ----------------------------------
    Reload Remote Calendars
    ----------------------------------
    Page Setup...
    Print...
    ----------------------------------
    Quit | Exit
    ----------------------------------

Removed currently not working entries 'New Journal Item' and 'Mail Selection'. 'Edit Selection...' moved to Edit menu. Mac and unix systems use 'Quit', Windows uses 'Exit'. For access keys markup see wiki page.
Suggested menu looks ok to me.
dmose, if you agree, please mark ui-review+
Comment on attachment 230772 [details] [diff] [review]
part 2: sunbird file menu, v2

obsoleting patch, per comment 18
Attachment #230772 - Attachment is obsolete: true
Attachment #230772 - Flags: second-review?(mvl)
Attachment #230772 - Flags: first-review?(jminta)
Updated version of patch because previous version of patch is rotten.
Attachment #236854 - Flags: second-review?
Attachment #236854 - Flags: first-review?(jminta)
Attachment #236854 - Flags: second-review? → second-review?(dmose)
This is mainly just polish stuff - but also the stuff a user sees/uses all the time. I several forum/newsgroup posts from user that doesn't understand the correct meaning of some menu items or did not found e.g. the calendar export functionality hidden in context menu. Therefore i think this will help us much.

Due to the l10n changes requesting blocking0.3.
Flags: blocking0.3?
Flags: blocking0.3? → blocking0.3+
Whiteboard: [cal-ui-review needed] → [cal-ui-review+][l10n impact]
Comment on attachment 236854 [details] [diff] [review]
part 2: sunbird file menu, v3

r=dmose; moving first review to lilmatt since jminta is busy.
Attachment #236854 - Flags: second-review?(dmose)
Attachment #236854 - Flags: second-review+
Attachment #236854 - Flags: first-review?(mattwillis)
Attachment #236854 - Flags: first-review?(jminta)
Whiteboard: [cal-ui-review+][l10n impact] → [cal-ui-review+][l10n impact][needs review lilmatt]
Comment on attachment 236854 [details] [diff] [review]
part 2: sunbird file menu, v3

r1=lilmatt
Attachment #236854 - Flags: first-review?(mattwillis) → first-review+
Patch checked in on MOZILLA_1_8_BRANCH and trunk.

-> FIXED
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Whiteboard: [cal-ui-review+][l10n impact][needs review lilmatt] → [cal-ui-review+][l10n impact]
verified.
Sunbird 2006100207/Windows
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.