XUL tabs aren't like the real OS X tabs

RESOLVED DUPLICATE of bug 231313

Status

RESOLVED DUPLICATE of bug 231313
13 years ago
10 years ago

People

(Reporter: hwaara, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
In firefox (XUL) there are two things that make different from the native, real tab views in Cocoa:

* They don't look like OS X tabs. See for example: http://developer.apple.com/documentation/Cocoa/Conceptual/TabView/Concepts/HowTabViewsWork.html
* If you click a tab button, it immediately switches, without waiting for mouse up. It should wait for me to really choose that button, not go on the actual mousedown.
The second item was intentional: see bug 293342 and bug 295721 comment 5 (which mentions that mousedown is the Mac default, oddly enough).

Comment 2

13 years ago
They're aren't native tabs - see comments in bug 231313 (although that mostly focusses on the difference between 10.2 and 10.3).

Comment 3

13 years ago

*** This bug has been marked as a duplicate of 231313 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

10 years ago
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.