DOM sees old value in textarea after changing the value

VERIFIED FIXED in M16

Status

()

Core
DOM
P3
normal
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: Jan Carpenter, Assigned: jst)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+])

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
Overview Description: 
If you use DOM to change the value in a textarea, then look at that value, DOM 
still sees the old value

Steps to Reproduce: 
- see testcase

Actual Results: 
DOM sees "default value 1" as the value of the textarea

Expected Results: 
DOM should see "fun fun fun" as the value of the textarea

Build Date & Platform Bug Found: 
All platforms
2000-03-21-06
(Reporter)

Comment 1

19 years ago
Created attachment 6775 [details]
attaching testcase
(Reporter)

Updated

19 years ago
Keywords: beta1
Target Milestone: ---

Comment 2

19 years ago
Please identify ASAP any known high-profile sites that depend on this.
Thanks,
Jim

Comment 3

19 years ago
Putting on the PDT- radar for beta.
Whiteboard: [PDT-]

Updated

19 years ago
QA Contact: gerardok → janc
(Reporter)

Comment 4

19 years ago
adding beta2 keyword, and removing pdt status
Keywords: beta2
Whiteboard: [PDT-]

Comment 5

19 years ago
removing beta1 keyword so it doesn't show up on beta1 radar
Keywords: beta1

Comment 6

18 years ago
This problem actually appears to be that getAttribute('value') and .value don't 
agree on the same value. Browsing through the code, it is probably because 
nsHTMLTextAreaElement::SetValue (in layout) does not call SetAttribute and thus 
setting .value has only a visible effect without changing the underlying 
property. (Then again, I don't fully understand the code)

Attached a new testcase demonstration the difference between getAttribute and 
.value

Comment 7

18 years ago
Created attachment 7688 [details]
Revised test case

Updated

18 years ago
Keywords: nsbeta2
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → M16

Comment 8

18 years ago
Fwded to rickg to get his opinion on PR2 stopper here.
Whiteboard: [NEED INFO]

Comment 9

18 years ago
Marking beta2+.
Whiteboard: [NEED INFO] → beta2+
(Assignee)

Comment 10

18 years ago
I just checked in a fix for this, marking FIXED.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Updated

18 years ago
Whiteboard: beta2+ → [nsbeta2+]
(Reporter)

Comment 11

18 years ago
verified fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.