buffer overrun with TITLE too long (when Mobipassword is installed)

RESOLVED INVALID

Status

()

Firefox
General
--
critical
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: Daragh Fitzpatrick, Unassigned)

Tracking

1.5.0.x Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [sg:needinfo], URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

if the title tag of a site is too long, it will cause the browser to creash with a buffer overrun error

Reproducible: Always

Steps to Reproduce:
1. go to i2i-tech.com/kill_firefox.htm
2.
3.

Actual Results:  
create a web page with the title tag containing 50 lines of text

Expected Results:  
buffer overrrun

truncated and displayed the site title
(Reporter)

Comment 1

12 years ago
Created attachment 212518 [details]
this will reproduce the error

Comment 2

12 years ago
WFM Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060218 Firefox/1.6a1

Comment 3

12 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060219 Firefox/1.6a1

Comment 4

12 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

Comment 5

12 years ago
I can't reproduce the crash, even using the same build you're using.
Whiteboard: [sg:needinfo]
(Reporter)

Comment 6

12 years ago
I'm using v1.5.0.1
Version: unspecified → 1.5 Branch
(Reporter)

Comment 7

12 years ago
This will also kill v1.6a1
wfm 
Mozilla/5.0 (Windows; U; Windows NT 5.2; de-DE; rv:1.9a1) Gecko/20060219 SeaMonkey/1.5a
(Reporter)

Comment 9

12 years ago
This issue is caused by the Mobipassword 2.0 extension. 
Reported to Mobipassword company (Icom)
http://www.mobipassword.com/mobipass/main.php?askus
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WONTFIX

Updated

12 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
Summary: buffer overrun - <TITLE too long → buffer overrun with TITLE too long (when Mobipassword is installed)

Updated

12 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.