Closed Bug 327998 Opened 19 years ago Closed 19 years ago

move accesskey label into xforms-xhtml.xml

Categories

(Core Graveyard :: XForms, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: surkov, Assigned: surkov)

References

Details

(Keywords: fixed1.8.0.4, fixed1.8.1)

Attachments

(4 files, 2 obsolete files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20051212 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20051212 Firefox/1.6a1

move accesskey label into xforms-xhtml.xml

Reproducible: Always
Blocks: 327236
Attached file testcase
Attached patch patch (obsolete) — Splinter Review
Attachment #212557 - Flags: review?(doronr)
Attachment #212557 - Flags: review?(doronr) → review+
Attachment #212557 - Flags: review?(allan)
Attached patch updateSplinter Review
Attachment #212557 - Attachment is obsolete: true
Attachment #212699 - Flags: review?(allan)
Attachment #212557 - Flags: review?(allan)
Assignee: aaronr → surkov
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #212699 - Flags: review?(allan) → review+
Checked into trunk
Whiteboard: xf-to-branch
Attached patch accesskey issue (obsolete) — Splinter Review
Now label-accesskey widget is based on label widget. The patch fixes non binded label-accesskey (invalid behaviour on second refresh).
Attachment #213220 - Flags: review?(doronr)
Attachment #213220 - Flags: review?(allan)
Attachment #213220 - Flags: review?(doronr) → review+
Blocks: 326556
*** Bug 329027 has been marked as a duplicate of this bug. ***
Attached file calc testcase
Looks like the 'accesskey issue' patch fixes my testcase on 329027, but then it rebreaks the calculator sample (which I am attaching here) that your previous patch fixes.  So when this patch is finished and ready for checkin, please verify that you can switch to SVG and back to 'normal' on this testcase and still pass the accesskey part of the other attached testcase.  Thanks.
(In reply to comment #7)
> Created an attachment (id=213676) [edit]
> calc testcase
> 
> Looks like the 'accesskey issue' patch fixes my testcase on 329027, but then it
> rebreaks the calculator sample (which I am attaching here) that your previous
> patch fixes.  So when this patch is finished and ready for checkin, please
> verify that you can switch to SVG and back to 'normal' on this testcase and
> still pass the accesskey part of the other attached testcase.  Thanks.
> 

The problem is like problem described in bug 313857. html:span element of xforms:label has zero width.
Attachment #213220 - Attachment is obsolete: true
Attachment #213880 - Flags: review?(allan)
Attachment #213220 - Flags: review?(allan)
Attachment #213880 - Flags: review?(doronr)
Comment on attachment 213880 [details] [diff] [review]
patch (calctest works)

>diff -uNra mozilla.orig/extensions/xforms/resources/content/xforms.css mozilla/extensions/xforms/resources/content/xforms.css
>--- mozilla.orig/extensions/xforms/resources/content/xforms.css	2006-03-01 18:34:30.000000000 +0800
>+++ mozilla/extensions/xforms/resources/content/xforms.css	2006-03-03 18:32:39.000000000 +0800
>@@ -280,14 +280,14 @@
>   color: GrayText !important;
> }
> 
>-html|*:root input > label,
>-html|*:root secret > label,
>-html|*:root textarea > label,
>-html|*:root trigger > label,
>-html|*:root submit > label,
>-html|*:root select > label,
>-html|*:root select1 > label,
>-html|*:root upload > label {
>+html|*:root input[accesskey] > label,
>+html|*:root secret[accesskey] > label,
>+html|*:root textarea[accesskey] > label,
>+html|*:root trigger[accesskey] > label,
>+html|*:root submit[accesskey] > label,
>+html|*:root select[accesskey] > label,
>+html|*:root select1[accesskey] > label,
>+html|*:root upload[accesskey] > label {
>   -moz-binding: url('chrome://xforms/content/xforms-xhtml.xml#xformswidget-label-accesskey');
> }

Do we need this root stuff?
Attachment #213880 - Flags: review?(doronr) → review+
(In reply to comment #10)

> 
> Do we need this root stuff?
> 

Yes, I guess we need because f.x. we should have other realization of accesskey label control for xul (The one reason is I guess it's not proper way to underline in xul like it done for xhtml accesskey-label).
Comment on attachment 213880 [details] [diff] [review]
patch (calctest works)

Is this patch still needed? The testcases seem to work on standard trunk build for me...
(In reply to comment #12)
> (From update of attachment 213880 [details] [diff] [review] [edit])
> Is this patch still needed? The testcases seem to work on standard trunk build
> for me...
> 

Yes, it's needed. The bug 329027 shows the problem. When label-accesskey gets second refresh then it will have wrong look.
Attachment #213880 - Flags: review?(allan) → review+
(In reply to comment #9)
> Created an attachment (id=213880) [edit]
> patch (calctest works)

Checked into trunk
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
Blocks: 332853
Whiteboard: xf-to-branch
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: