Opacity of elements with greater opacity than parent not respected.

RESOLVED INVALID

Status

Core Graveyard
GFX
RESOLVED INVALID
12 years ago
9 years ago

People

(Reporter: Brendan Jurd, Unassigned)

Tracking

1.8 Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060207 Debian/1.5.dfsg+1.5.0.1-1 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060207 Debian/1.5.dfsg+1.5.0.1-1 Firefox/1.5.0.1

If an element has a greater opacity than its parent element, the greater opacity value appears to be ignored, or treated as "inherit".

This means you can't show a fully opaque element within a partially opaque element.

I don't understand this behaviour, and it would seem to be contrary to the CSS3 spec for opacity.

Reproducible: Always

Steps to Reproduce:
1. View my test case
Actual Results:  
The span "this span of text" in the second paragraph displays at the same level of opacity as its parent paragraph.

Expected Results:  
The span should be displaying as totally opaque, since its style attribute specifies "opacity: 1;".  It should display with a pure white background.
(Reporter)

Comment 1

12 years ago
Created attachment 212565 [details]
Minimal testcase

Demonstrates the unexpected rendering.
Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9a1) Gecko/20060221 Firefox/1.6a1 ID:0000000000
Confirmed.
Status: UNCONFIRMED → NEW
Component: General → GFX
Ever confirmed: true
Product: Firefox → Core
Version: unspecified → 1.0 Branch
Version: 1.0 Branch → 1.8 Branch

Comment 3

12 years ago
Invalid.  Opacity isn't inherited; instead, it affects all descendants.  That's how it's specified in the CSS3 spec and I think it makes sense too.

See bug 312518 or bug 250273.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
(Assignee)

Updated

9 years ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.