"Search messages" returns results that do not contain the search string

RESOLVED DUPLICATE of bug 37031

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 37031
13 years ago
10 years ago

People

(Reporter: Mark H, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

If I try to search messages in my Inbox by setting "body" "contains" <search string>, messages are found that do not contain the string.

Most of these false-positive messages will have attachments.  (.pdf's, .zip's etc.)

Tested this with 1.5 and now with version 1.6a1 (20060220), just installed today.

Reproducible: Always

Steps to Reproduce:
1. Go into Edit>Find>Search Messages
2. Check "Search Subfolders" and "Match any of the following"
3. Set search criteria to "Body" "Contains"
4. Enter test search string
5. Select item from results window and check if it contains the string.

Actual Results:  
Finds messages that do not contain the specified string

Expected Results:  
Should not find messages that do not contain the specified string

Using default theme

Comment 1

13 years ago
(In reply to comment #0)
> Most of these false-positive messages will have attachments.  (.pdf's, .zip's
> etc.)

Duplicate of bug 282682/bug 272042 -> Core bug 136055 (and/or bug 249297 -> Suite bug 98141)?
(Reporter)

Comment 2

13 years ago
Duplicate of Core bug 136055 and/or 98141?

136055 - No.  That's a similar problem but its about message filtering, not manual searching.  (Maybe the search routines are the same piece of code though?)

98141 - Similar.  What I notice that's different is that you don't have to have an attachment to get false positives.  The search function also returns false positives with html encoded content, for example.

Comment 3

13 years ago
When using IMAP mail, I have this problem.  A body search returns EVERY email in my inbox.  

However, if I download my Inbox, go offline, and then do the exact same search it works right.

This makes sense as the IMAP headers are by default only brought to the local PC.  The body is only brought down once the email is viewed or downloaded... Perhaps this should be an enhancement request to at least search the downloaded or read emails and only return those matches rather than ALL emails.

Comment 4

13 years ago
Steve, the difference there is where the search is done - when you search online, by default we search on the imap server itself, and it sounds like your imap server is returning all messages, i.e., search is a little broken on the server.

Comment 5

11 years ago
Likely that all of these cases are a dupe of one or more bugs


(In reply to comment #2)
> Duplicate of Core bug 136055 and/or 98141?

both bugs got duped to bug 37031 which is still open - searching message body yields false positives because base64 encoded binary attachments are treated as plaintext


> 98141 - Similar.  What I notice that's different is that you don't have to have
> an attachment to get false positives.  The search function also returns false
> positives with html encoded content, for example.

There are several bugs about searching various encodings and charset. Please attach a testcase message.
Assignee: mscott → nobody
Whiteboard: DUPEME, closeme 2008-04-10
Wayne, resolve or dupe?

Comment 7

10 years ago
I'd say best gusss dupe.  I only questioned it in case someone volunteered a testcase which would perhaps prove it's not a known bug - and no one has.
Duping to 37031, based on comment #7.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME, closeme 2008-04-10
Duplicate of bug: 37031
You need to log in before you can comment on or make changes to this bug.