Don't apply (partial) updates when other instances are running with -no-remote

RESOLVED DUPLICATE of bug 314148

Status

()

Toolkit
Application Update
RESOLVED DUPLICATE of bug 314148
12 years ago
10 years ago

People

(Reporter: dolphinling, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
If I get an update downloaded and choose to not restart right away, then open another instance of firefox with -no-remote, the update gets applied. This has at least lead to XML well-formedness errors in things like the Download/Extension managers, and might cause more problems.

The update should not be applied unless there are no running instances of firefox (or perhaps no running instances of that copy of firefox, if that's possible)
I've seen the UI for this situation on windows, but the update fails because the files are locked and Firefox is unaffected. Perhaps the code that detects running firefox's can be adapted to this task.

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 314148
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.