Closed Bug 328086 Opened 15 years ago Closed 15 years ago

Scrollbars showing even when div visibility:hidden

Categories

(SeaMonkey :: General, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 187435

People

(Reporter: kennylucius, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

A div with visibility:hidden contains a form with a textarea. The textarea contains enough text to activate the scrollbars. The scrollbars are visible even when the div is hidden. Furthermore, the scrollbars appear on top of other divs that should cover them.

Reproducible: Always

Steps to Reproduce:
1.create a textarea element filled with enough text to activate scrollbars
2.place the textarea inside a div with visibility:hidden

Actual Results:  
The scrollbars are visible even though the other contents of the hidden div are not visible. Furthermore, the scrollbars appear over other divs that should cover them.

Expected Results:  
No scrollbars should be visible.

This bug also appears in Firefox.

*** This bug has been marked as a duplicate of 187435 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.