When source HTML is on a single line is not visualized correctly

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
13 years ago
10 years ago

People

(Reporter: gidanmx2, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 2007-07-10)

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

When source HTML is on a single line is not visualized correctly.  If watched the source of the page, that I have given to you, you will notice that tag "< style >" as hidden.

Reproducible: Always

Steps to Reproduce:
1. create one page HTML with the source on one single line
2. run firefox
3. Show Source

Actual Results:  
<html><title></title><head> <style type="text/css"            </head><body></body></html>

Expected Results:  
<html><title></title><head> <style type="text/css">body { background-color: #000000; }</style>            </head><body></body></html>

Comment 1

13 years ago
Created attachment 212833 [details]
Screen Shot of corrupted text printed in the view source window for web page of the bug's url
(Reporter)

Comment 2

13 years ago
Moreover firefox adds some spaces, like in a justified text, such spaces in truth not are.

Comment 3

12 years ago
Could you please try to reproduce this bug with a current Firefox build (particulary, one from <http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/contrib/latest-trunk/>)?

Thanks.

Also, <http://www.koalasoft.net/koala/> has changed and is not on a single line anymore.

Updated

12 years ago
Whiteboard: CLOSEME 2007-07-10

Comment 4

12 years ago
Created attachment 268939 [details]
Testcase for bug - HTML source fitted in one line

Made a rough testcase with a HTML file from the site in question although it seems their pages have been altered since the bug was opened.

Comment 5

12 years ago
WFM on latest trunk build. Used Windows XP with clean profile.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a6pre) Gecko/2007061804 Minefield/3.0a6pre
Reporter or anyone else, if you still see this problem with the latest Firefox 2 and/or Firefox 3/Trunk Version please reopen this bug.
Closing as WORKSFORME.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.