Cannot scroll through folders when add/edit filter > move message to > select folder

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
RESOLVED WORKSFORME
12 years ago
11 years ago

People

(Reporter: Mike Westkamper, Assigned: Scott MacGregor)

Tracking

x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

When add/edit filter > move message to > select from the list of folders 

scrolling down the list it will only scroll one visible list worth of folders. Going further it will return to the last folder selected plus the length of the list. If you have a lot of folders it gets really tedious.

Reproducible: Always

Steps to Reproduce:
1. Tools
2. Message Filters
3. Select a filter
4. Edit
5. Perform these actions: list("Move Message to")
6. select a folder (list box), use scroll bar, scroll down
7. If you go beyond the end of the list visible when you started, it resets to the item last seleted plus the length of the list.

Actual Results:  
As desribed

Expected Results:  
It would scroll down normally

Comment 1

11 years ago
thunderbird 2 and trunk implement the tree list fully populated as a flat list.  So you don't have to traverse the tree/folder list.

WFM version 3 alpha 1 (20070130)  (but probably a dupe)

Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Component: General → Mail Window Front End
Resolution: --- → WORKSFORME
Version: unspecified → 1.5
You need to log in before you can comment on or make changes to this bug.