can't find any detailed documentation about frame construction

RESOLVED DUPLICATE of bug 328275

Status

Developer Documentation
General
--
enhancement
RESOLVED DUPLICATE of bug 328275
13 years ago
6 years ago

People

(Reporter: yubo, Assigned: Dawn Endico)

Tracking

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040207 Firefox/0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040207 Firefox/0.8

I am studying clss nsCSSFrameConstructor to learn the constructing sequence of frames,but can't find any detailed documentation about the class . 
 For example ,there is a html file which looks like this:
<html>
<body>
hello!
</body>
</html>
A TextFrame is created for word "hello!",but I don't know how it is created,and when creation end ,what the frame tree looks like. And how can I walk through the frame tree.

where Can I find the detailed documentation or who can point me?

Reproducible: Always

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 328275 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
*** This bug has been confirmed by popular vote. ***
Component: Mozilla Developer → Documentation Requests
Ever confirmed: true
Product: Documentation → Mozilla Developer Center
Component: Documentation Requests → Documentation
Product: Mozilla Developer Network → Mozilla Developer Network
Component: Documentation → General
Product: Mozilla Developer Network → Developer Documentation
You need to log in before you can comment on or make changes to this bug.