doesn't build without pango

RESOLVED FIXED

Status

()

--
major
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: wbrana, Assigned: vlad)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060222 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060222 Firefox/1.6a1

Fx trunk cairo-gtk2 doesn't build without pango
.mozconfig:

ac_add_options --enable-xft
ac_add_options --enable-shared
ac_add_options --enable-canvas
ac_add_options --enable-application=browser
ac_add_options --enable-crypto
ac_add_options --enable-single-profile
ac_add_options --enable-strip
ac_add_options --enable-default-toolkit=cairo-gtk2
ac_add_options --enable-glitz
ac_add_options --enable-optimize="-s -pipe"
ac_add_options --enable-elf-dynstr-gc
ac_add_options --enable-reorder

ac_add_options --disable-static
ac_add_options --disable-pango
ac_add_options --disable-js-static-build
ac_add_options --disable-ldap
ac_add_options --disable-mailnews
ac_add_options --disable-profilesharing
ac_add_options --disable-debug
ac_add_options --disable-installer
ac_add_options --disable-gtktest
ac_add_options --disable-glibtest
ac_add_options --disable-tests
ac_add_options --disable-updater
ac_add_options --disable-composer
ac_add_options --disable-mathml
ac_add_options --disable-gnomevfs
ac_add_options --disable-gnomeui
ac_add_options --disable-xprint
ac_add_options --disable-freetype2
ac_add_options --disable-system-cairo
ac_add_options --disable-accessibility
ac_add_options --disable-svg



Reproducible: Always

Actual Results:  
c++ -o gfxPangoFonts.o -c -I../../../dist/include/system_wrappers -include ../../../config/gcc_hidden.h -DMOZILLA_INTERNAL_API -DOSTYPE=\"Linux2.6\" -DOSARCH=\"Linux\" -DBUILD_ID=0000000000  -I../../../dist/include/cairo -I../../../dist/include/libpixman -I../../../dist/include/string -I../../../dist/include/pref -I../../../dist/include/xpcom -I../../../dist/include/glitz -I../../../dist/include/glitzglx -I../../../dist/include   -I../../../dist/include/thebes -I../../../dist/include/nspr    -I../../../dist/sdk/include    -fPIC   -fno-rtti -fno-exceptions -Wall -Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wno-long-long -pedantic -s -pipe -fshort-wchar -pthread -pipe  -DNDEBUG -DTRIMMED -ffunction-sections -s -pipe -I../../../dist/include/cairo -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include   -I../../../dist/include/cairo    -DMOZILLA_CLIENT -include ../../../mozilla-config.h -Wp,-MD,.deps/gfxPangoFonts.pp gfxPangoFonts.cpp
In file included from gfxPangoFonts.cpp:64:
../../../dist/include/system_wrappers/freetype/tttables.h:3:36: error: freetype/tttables.h: No such file or directory
In file included from ../../../dist/include/system_wrappers/ft2build.h:3,
                 from /usr/include/pango-1.0/pango/pangofc-font.h:25,
                 from ../../../dist/include/system_wrappers/pango/pangofc-font.h:3,
                 from /usr/include/pango-1.0/pango/pango-ot.h:25,
                 from /usr/include/pango-1.0/pango/pangoxft.h:27,
                 from ../../../dist/include/system_wrappers/pango/pangoxft.h:3,
                 from gfxPangoFonts.cpp:68:
/usr/include/ft2build.h:56:38: error: freetype/config/ftheader.h: No such file or directory
In file included from ../../../dist/include/system_wrappers/pango/pangofc-font.h:3,
                 from /usr/include/pango-1.0/pango/pango-ot.h:25,
                 from /usr/include/pango-1.0/pango/pangoxft.h:27,
                 from ../../../dist/include/system_wrappers/pango/pangoxft.h:3,
                 from gfxPangoFonts.cpp:68:
/usr/include/pango-1.0/pango/pangofc-font.h:26:10: error: #include expects "FILENAME" or <FILENAME>
In file included from ../../../dist/include/system_wrappers/X11/Xft/Xft.h:3,
                 from /usr/include/pango-1.0/pango/pangoxft-render.h:32,
                 from /usr/include/pango-1.0/pango/pangoxft.h:30,
                 from ../../../dist/include/system_wrappers/pango/pangoxft.h:3,
                 from gfxPangoFonts.cpp:68:
/usr/include/X11/Xft/Xft.h:42:10: error: #include expects "FILENAME" or <FILENAME>
In file included from gfxPangoFonts.cpp:70:
../../../dist/include/cairo/cairo-ft.h:48:10: error: #include expects "FILENAME" or <FILENAME>
/usr/include/pango-1.0/pango/pangofc-font.h:111: error: expected identifier before &#8216;*&#8217; token
/usr/include/pango-1.0/pango/pangofc-font.h:111: error: &#8216;FT_Face&#8217; declared as function returning a function
/usr/include/pango-1.0/pango/pangofc-font.h:144: error: &#8216;FT_Face&#8217; does not name a type
/usr/include/pango-1.0/pango/pango-ot.h:57: error: &#8216;FT_Face&#8217; was not declared in this scope
/usr/include/X11/Xft/Xft.h:62: error: &#8216;FT_Library&#8217; does not name a type
/usr/include/X11/Xft/Xft.h:96: error: &#8216;FT_UInt&#8217; does not name a type
/usr/include/X11/Xft/Xft.h:103: error: &#8216;FT_UInt&#8217; does not name a type
/usr/include/X11/Xft/Xft.h:200: error: expected &#8216;,&#8217; or &#8216;...&#8217; before &#8216;*&#8217; token
/usr/include/X11/Xft/Xft.h:305: error: expected &#8216;,&#8217; or &#8216;...&#8217; before &#8216;*&#8217; token
/usr/include/X11/Xft/Xft.h:363: error: &#8216;FT_Face&#8217; does not name a type
/usr/include/X11/Xft/Xft.h:403: error: expected &#8216;,&#8217; or &#8216;...&#8217; before &#8216;*&#8217; token
/usr/include/X11/Xft/Xft.h:409: error: expected &#8216;,&#8217; or &#8216;...&#8217; before &#8216;*&#8217; token
/usr/include/X11/Xft/Xft.h:418: error: &#8216;FT_UInt&#8217; has not been declared
/usr/include/X11/Xft/Xft.h:419: error: &#8216;FT_UInt&#8217; has not been declared
/usr/include/X11/Xft/Xft.h:427: error: &#8216;FT_UInt&#8217; does not name a type
/usr/include/X11/Xft/Xft.h:471: error: expected &#8216;,&#8217; or &#8216;...&#8217; before &#8216;*&#8217; token
/usr/include/pango-1.0/pango/pangoxft.h:81: error: &#8216;FT_Face&#8217; does not name a type
../../../dist/include/cairo/cairo-ft.h:60: warning: &#8216;cairo_ft_font_face_create_for_ft_face&#8217; initialized and declared &#8216;extern&#8217;
../../../dist/include/cairo/cairo-ft.h:60: error: &#8216;FT_Face&#8217; was not declared in this scope
../../../dist/include/cairo/cairo-ft.h:61: error: expected primary-expression before &#8216;int&#8217;
../../../dist/include/cairo/cairo-ft.h:61: error: initializer expression list treated as compound expression
../../../dist/include/cairo/cairo-ft.h:63: error: &#8216;FT_Face&#8217; does not name a type
gfxPangoFonts.cpp: In member function &#8216;virtual const gfxFont::Metrics& gfxPangoFont::GetMetrics()&#8217;:
gfxPangoFonts.cpp:405: error: &#8216;FT_Face&#8217; was not declared in this scope
gfxPangoFonts.cpp:405: error: expected `;' before &#8216;face&#8217;
gfxPangoFonts.cpp:406: error: &#8216;TT_OS2&#8217; was not declared in this scope
gfxPangoFonts.cpp:406: error: &#8216;os2&#8217; was not declared in this scope
gfxPangoFonts.cpp:411: error: &#8216;face&#8217; was not declared in this scope
gfxPangoFonts.cpp:411: error: &#8216;XftLockFace&#8217; was not declared in this scope
gfxPangoFonts.cpp:412: error: expected primary-expression before &#8216;)&#8217; token
gfxPangoFonts.cpp:412: error: expected `;' before &#8216;FT_Get_Sfnt_Table&#8217;
gfxPangoFonts.cpp:446: error: &#8216;FT_MulFix&#8217; was not declared in this scope
Confirmed with the latest CVS revision on trunk. It does, however, compile fine if you add --enable-pango.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Created attachment 214496 [details] [diff] [review]
require pango for gtk2

Require pango if a gtk2 cairo build is being done.
Assignee: nobody → vladimir
Status: NEW → ASSIGNED
Attachment #214496 - Flags: review?(pavlov)
*** Bug 324095 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Attachment #214496 - Flags: review?(pavlov) → review+
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.