text corruption /distortion / displacement caused by autoscroll icon

VERIFIED INCOMPLETE

Status

()

Firefox
General
--
minor
VERIFIED INCOMPLETE
12 years ago
7 years ago

People

(Reporter: Daniel Schneider, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2009-08-01, URL)

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

On certain pages, the use of middle-button autoscrolling causes text corruption to appear. I can reliably reproduce it by randomly middle-clicking and moving the mouse around over the main text.

The attached screenshot shows how the circular autoscrolling icon causes the text distortion. I can see around the circle, the underlying square used as the icon. The top of the square is positioned halfway up the "got plenty" text, and the part it covers is horizontally shifted by a couple pixels. Normally if I scroll up and down, the text re-aligns properly; however, it can remain corrupted at the point where the autoscroll is stopped and the icon removed (i.e. click the middle button around a lot). The text returns to normal when it is selected, or scrolled off the window, etc.

I have seen this problem ever since I used Firefox but never did anything about it. I can't seem to find a duplicate. It may be related to bug 278442 or bug 273029 which are vague.


Reproducible: Always

Steps to Reproduce:
1. go to the above URL (for example) with autoscrolling enabled
2. click the middle button to turn autoscroll on and off while moving the cursor around the main text


Actual Results:  
the text gets horizontally smeared

Expected Results:  
normal text

I think everything is default... I don't think it's relevant but my video card is an ATI Radeon 9800 Pro, and Windows GUI is set to 125% DPI, 1024x768@32.
(Reporter)

Comment 1

12 years ago
Created attachment 212954 [details]
illustrates display problem
(Reporter)

Comment 2

12 years ago
Actually maybe the DPI is relevant. I tried to reproduce on another PC and couldn't, until I changed the DPI setting (Display Properties->Settings->Advanced->General-> DPI setting "Large size (120 DPI)"

The other PC is also an ATI card though.

Comment 3

12 years ago
hi ,,i could not reproduce it..

Comment 4

11 years ago
I see distortion/displacement in the vertical plane, but not horizontal and only when page is scrolling.  VERY apparent.

dpi=96, appearance="large fonts", NVIDIA Geforce FX 5200, screen 1280x1024, 32bit

would bug 242621 fix this?
Summary: text corruption caused by autoscroll icon → text corruption /distortion / displacement caused by autoscroll icon

Comment 5

11 years ago
Created attachment 259224 [details]
screen shot see top left

Comment 6

11 years ago
Does this still happen on Firefox trunk (e.g. Firefox 3 Alpha 6) now that bug 242621 is fixed?

Comment 7

9 years ago
Do you still see this problem using Firefox 3.5?  Please update the bug, and close/alter bug if appropriate.
Whiteboard: closeme 2009-08-01
No reply, INCO. Please reopen if you are seeing this in Firefox 3.5.2 or later in Firefox safe mode and a new profile with the latest plugins.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Profiles
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE

Updated

7 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.