href enclosing an image and text displays an underling on both image and text

RESOLVED DUPLICATE of bug 193584

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 193584
12 years ago
12 years ago

People

(Reporter: bob sinton, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

The following code produces an underline under the image and text when the cursor hovers with Firefox but not with IE6.

<td width="25%" valign="top"><div align="center"><span style="font-family: Arial, Helvetica, sans-serif; font-size: 12px"><a href="qs-fish-range.php"><img src="images/qs-fish-200.jpg" width="200" height="100" border="0" /><br />Fish Series</a></span></div></td>



Reproducible: Always




The following CSS code applies to the link text

A:link {
	font-weight: bold;
	color:000044;
	text-decoration: none;
}
A:visited {
	font-weight: bold;
	color:000044;
	text-decoration: none;
}
A:hover {
	font-weight: bold;
	color:cc0000;
	text-decoration: underline;
}

If the image and text are treated as separate links there is no problem.

Comment 1

12 years ago
Related to/duplicate of Core bug 307095, Core bug 200091 or Core bug 193584?
Looks like it to me


*** This bug has been marked as a duplicate of 193584 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.