local ip adresses should by definition not be regarded as scam since they're local lan

RESOLVED DUPLICATE of bug 308366

Status

--
minor
RESOLVED DUPLICATE of bug 308366
13 years ago
13 years ago

People

(Reporter: janklopper, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

Thunderbird sees numeric ip adresses as scam links, local lan ip's should however be granted to go around this scam detection since lan ip's could never reach the scammer's server, and are probably links from developpers or sys-admins on local networks to their users.

the following ip ranges come to mind:
127.*
10.*
192.*

and probably some others as described in the apropriate RFC.

Reproducible: Always

Steps to Reproduce:
1.send link with local ip to user
2.open email, notice the scam alert
3.click and go to the server on the local lan, scamming the user into pay money to the sysadmin??

Comment 1

13 years ago
Related to bug 308366 comment 7 and bug 305089 (the Note: part)?
(Reporter)

Comment 2

13 years ago
bug 308366 comment 7 is exactly what this is.

Local (as by RFC) ip's should not be triggering scam messages.

*** This bug has been marked as a duplicate of 308366 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.