Can't select/copy cookie properties in View Cookies

RESOLVED FIXED in Firefox 2 alpha1

Status

()

defect
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: klassphere, Assigned: Gavin)

Tracking

({fixed1.8.1, regression})

2.0 Branch
Firefox 2 alpha1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060224 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060224 Firefox/1.6a1

Can't select/copy cookie properties in View Cookies. (non-Cairo trunk)

Reproducible: Always

Steps to Reproduce:
1. Tools | Option 
2. Privacy | Cookies | View Cookies
3. Open a cookie folder and select some cookie to see properties such as Name, Content, Host, etc.

Actual Results:  
Cookie properties are grayed out and can't be selected to copy.

Expected Results:  
It should be selectable by the mouse.
This is a regression between 1.9a1_2006012517 and 1.9a1_2006012609.
I don't see it in branch.
Keywords: regression
Weird, it's just toggling .disabled.
Removing the <stack> in cookies.xul should make it work again.
Hmm, why does removing the stack help? Just removing backgroundBox seemed to fix it well enough (backgroundBox is styled to be opacity: 0.5), but got rid of the nice gray background. Seems like the opacity stuff was just broken before and this dialog relied on that?

(I also noticed that the backgroundBox isn't styled on the Mac, not sure if that's intentional or not)
The stack needs a mousethrough="always", then it's working again like desired.
But it seems to me that the stack and the backgroundBox can just be removed and then move the styles from the backgroundBox to the grid. I think that should work just fine.
Posted patch patchSplinter Review
Thanks for the help Martijn. I made the changes you suggested, and also removed the labels from the array of items to be disabled since I don't think it really makes sense to disable the labels themselves.
Assignee: nobody → gavin.sharp
Status: NEW → ASSIGNED
Attachment #213592 - Flags: review?(mconnor)
Attachment #213592 - Flags: approval-branch-1.8.1?(mconnor)
(this bug isn't present on the branch, but I think this cleanup should be applied there too)
Attachment #213592 - Flags: review?(mconnor)
Attachment #213592 - Flags: review+
Attachment #213592 - Flags: approval-branch-1.8.1?(mconnor)
Attachment #213592 - Flags: approval-branch-1.8.1+
mozilla/browser/themes/winstripe/browser/preferences/preferences.css 	1.6.8.3
mozilla/browser/components/preferences/cookies.xul 	1.5.2.2
mozilla/browser/components/preferences/cookies.js 	1.9.2.4
Keywords: fixed1.8.1
OS: Windows XP → All
Hardware: PC → All
mozilla/browser/components/preferences/cookies.js 	1.13
mozilla/browser/components/preferences/cookies.xul 	1.7
mozilla/browser/themes/winstripe/browser/preferences/preferences.css 	1.9
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 2 alpha1
Version: Trunk → 2.0 Branch
You need to log in before you can comment on or make changes to this bug.