rss.rdf is not shipped when using 'make install'

RESOLVED DUPLICATE of bug 301945

Status

MailNews Core
Feed Reader
RESOLVED DUPLICATE of bug 301945
12 years ago
9 years ago

People

(Reporter: Dan Nicholson, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Thunderbird 1.5 (X11/20060218)

When installing Thunderbird from source using `make install' or `make -f client.mk install', the RSS extension is not installed.  This is seen in the Account Wizard which does not list the option to add an RSS News feed.  This situation is similar to the Movemail extension not being installed referenced in Bug 281084.

This issue does not affect the distributed binaries since rss.rdf does get installed to $(EXPORT_DIR).  mail/extensions/newsblog/Makefile.in is lacking an install:: target, though.

Reproducible: Always

Steps to Reproduce:
1. Install to system with `make install' or `make -f client.mk install'
2. Start Thunderbird and open Account Wizard
3. Note that RSS News is not offered

Actual Results:  
RSS News is not offered

Expected Results:  
Offer RSS News feeds
(Reporter)

Comment 1

12 years ago
Created attachment 213083 [details] [diff] [review]
Adds install:: target to mail/extensions/newsblog/Makefile.in and cleans targets a bit

Here's a patch that adds the install:: target and cleans up Makefile.in in the style of mailnews/base/ispdata/Makefile.in.

Comment 2

12 years ago

*** This bug has been marked as a duplicate of 301945 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Updated

9 years ago
Component: RSS → Feed Reader
Product: Thunderbird → MailNews Core
You need to log in before you can comment on or make changes to this bug.