bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Mouse pointer garbles text when changing from caret to arrow

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: Juan Lanus, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

When scrolling a text page with the keyboard the area that passes under the mouse pointer gets garbled frequently.
This happens sometimes when the mouse pointer changes from caret to arrow and you scroll one line. 
Seems to depend on the blinking state, maybe if the scroll happens when the caret dissapearad and has to reappear as arrow then the position of the area to be redrawn has an error on it's height.
I'm attaching a picture of a Bugzilla search page after scrolling up and down several times. 
It happens in an 800MHz, 512MB Pentium. It might be processor-speed dependent.

Reproducible: Always

Steps to Reproduce:
1.Go Bugzilla, search for "mouse pointer"
2.Leave the mouse pointer in the center of the screen
3.Scroll up and down using the arrows, in one line steps
(Reporter)

Comment 1

13 years ago
Created attachment 213173 [details]
garbled text sample

I couldn't reproduce this behaviour in Mozilla 1.7.12
(Reporter)

Comment 2

13 years ago
Further research says it's a problem of the video controller (S3 Savage4 PCI).
It only happens in Firefox, this is curious. It's because Firefox changes the cursor from arrow to caret all the time, while Mozilla doesn't.
But it happens in MSIE, it might be the same bug!  :-)
Both programs do it only in one of my monitors.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.