word *.doc file not recognized as *.doc file when downloaded as e-mail attatchment

VERIFIED WORKSFORME

Status

Camino Graveyard
Downloading
VERIFIED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Jim, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060214 Camino/1.0
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060214 Camino/1.0

When using Camino to look at e-mail from mac.com attatched *.doc files that I download are not recognized by Word as *.doc files and will not open. However, when I used firefox to to download these same files everything worked fine.  

Reproducible: Always

Steps to Reproduce:
1.Go to mac.com mail using Camino
2.Download an attatched *.doc file from an e-mail
3.Open *.doc file with Word and a dialog box pops up that says "Word cannot open this document.The document might be in use or might not be a valid Word document."
4.If the above steps are done using Firefox instaed of Camino everything works fine.
Actual Results:  
See above

Expected Results:  
Opened the Word document.

Comment 1

13 years ago
This is most likely a problem with Apple's server not properly setting the MIME type of the files, and as such, isn't Camino's fault. (Firefox -- and Safari, for that matter -- has a very irritating tendency to make assumptions about what file extensions mean, contrary to the whole point of MIME types.)

cl

Comment 2

13 years ago
Does Word actually care about MIME types?  This sounds more like the download might be incomplete or corrupted in some way.

If you compare a file as downloaded with Camino to the same file downloaded by Firefox, are the file sizes the same?  Do they have the same checksum? (To check, open Terminal and type: "md5 ", then drag-and-drop the file onto the terminal, hit enter, and repeat with the other file, and see if what's printed out matches)
(Reporter)

Comment 3

13 years ago
It seems the problem was caused by a bad cable modem. When I pinged a web site I was losing 20 to 30% of the packets. My cable modem was replaced today and the download worked fine with Camino.

Comment 4

13 years ago
WFM per reporter in comment 3.

cl
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.