style.visibility Javascript property does not return a value unless explicitly set.

RESOLVED DUPLICATE of bug 196156

Status

()

Firefox
General
--
minor
RESOLVED DUPLICATE of bug 196156
13 years ago
13 years ago

People

(Reporter: penagate, Unassigned)

Tracking

unspecified
x86
Windows XP
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1.04 KB, application/xhtml+xml
Details
(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

The .style.visibility property of an element does not return a value unless one is explicitly set in CSS or through Javascript. Since the default (and hence actual) visibility level is "visible", one would expect that to be returned rather than a blank string.

Reproducible: Always

Steps to Reproduce:
1. Create an element without an explicitly set CSS visible property.
2. Retrieve its .style.visibility property through Javascript.
Actual Results:  
The return value is blank.

Expected Results:  
Actual visibility of the element returned ("visible").
(Reporter)

Comment 1

13 years ago
Created attachment 213207 [details]
Testcase/demonstration
(Reporter)

Updated

13 years ago
Flags: testcase+

Comment 2

13 years ago
Related to/duplicate of Core bug 196156 or Core bug 136158 comment 4?

Comment 3

13 years ago
See Bug 196156 comment 1.

Marking this a dupe of that (invalid) bug.

*** This bug has been marked as a duplicate of 196156 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.