if I do a search on just one product, there should be a 'new bug against this product' link

RESOLVED FIXED in Bugzilla 3.0

Status

()

Bugzilla
Query/Bug List
P4
enhancement
RESOLVED FIXED
12 years ago
11 years ago

People

(Reporter: Luis Villa, Assigned: Vlad Dascalu)

Tracking

2.23
Bugzilla 3.0
Bug Flags:
approval +

Details

Attachments

(1 attachment, 3 obsolete attachments)

847 bytes, patch
Frédéric Buclin
: review+
Details | Diff | Splinter Review
(Reporter)

Description

12 years ago
Behavior:
* decide I want to report a bug.
* search for duplicates in the relevant product X.
* scan the search results.
* decide I need to file a bug.
* hit 'new'
* get presented with a list of products, even though bugzilla already knows I'm very interested in product X.

Bugzilla should be smart, know I just searched against product X, and give me the opportunity to file a bug directly against product X, instead of having to scan the entire product list Yet Again.
(Assignee)

Updated

12 years ago
Severity: normal → enhancement
OS: Linux → All
Hardware: PC → All
(Assignee)

Updated

12 years ago
Assignee: query-and-buglist → vladd
Target Milestone: --- → Bugzilla 2.24
(Assignee)

Comment 1

12 years ago
Created attachment 213265 [details] [diff] [review]
Fresh Meat, v1

If we want this, we probably want it especially when the search returned 'Zarro bugs', so placing the link next to the buglist-processing footer links is not really suitable.
Attachment #213265 - Flags: review?(LpSolit)
(Assignee)

Updated

12 years ago
Attachment #213265 - Attachment is obsolete: true
Attachment #213265 - Flags: review?(LpSolit)
(Assignee)

Comment 2

12 years ago
Created attachment 213266 [details] [diff] [review]
Fresh Meat, v2

Forgot to FILTER html the name of the product.
Attachment #213266 - Flags: review?(LpSolit)

Comment 3

12 years ago
Comment on attachment 213266 [details] [diff] [review]
Fresh Meat, v2

>+[% IF cgi.param('product') %]
>+  <p>
>+    <a href="enter_bug.cgi?product=[% cgi.param('product') FILTER url_quote %]">Fill
>+      a new bug in the [% cgi.param('product') FILTER html %] product</a>
>+  </p>
>+[% END %]


This doesn't work. If you do a search on several products, your url contains "&product=foo&product=bar" and you get:

"Fill a new bug in the ARRAY(0x8dfbdb4) product" whose URL is... enter_bug.cgi?product=ARRAY%280x8dfbde4%29
Attachment #213266 - Flags: review?(LpSolit) → review-
(Assignee)

Comment 4

12 years ago
Created attachment 213738 [details] [diff] [review]
Fresh Meat, v3
Attachment #213266 - Attachment is obsolete: true
Attachment #213738 - Flags: review?(LpSolit)

Comment 5

12 years ago
Comment on attachment 213738 [details] [diff] [review]
Fresh Meat, v3

Your patch doesn't pass tests:

not ok 202 - template/en/default/list/list.html.tmpl contains invalid bare words (e.g. 'bug') --WARNING

#     Failed test (t/009bugwords.t at line 90)
231: ">Fill
      a new bug in the

'a new bug' must be 'a new [% terms.bug %].

Moreover, I think you should enclose the product name in quotes, to make the UI better.

Note that if you run one of your saved searches and this saved search only queries on one product only, the link is not available. But I think that's not a problem.

Fix the problem above, add quotes, and I will r+ your patch.
Attachment #213738 - Flags: review?(LpSolit) → review-
(Assignee)

Comment 6

12 years ago
Created attachment 213995 [details] [diff] [review]
Fresh Meat, v4
Attachment #213738 - Attachment is obsolete: true
Attachment #213995 - Flags: review?(LpSolit)

Comment 7

12 years ago
Comment on attachment 213995 [details] [diff] [review]
Fresh Meat, v4

r=LpSolit
Attachment #213995 - Flags: review?(LpSolit) → review+

Updated

12 years ago
Status: NEW → ASSIGNED
Flags: approval?
(Assignee)

Updated

12 years ago
Priority: -- → P4
Version: unspecified → 2.23
Flags: approval? → approval+

Comment 8

12 years ago
Checking in template/en/default/list/list.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/list/list.html.tmpl,v  <--  list.html.tmpl
new revision: 1.47; previous revision: 1.46
done
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 9

12 years ago
*** Bug 253131 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

12 years ago
Blocks: 342130
You need to log in before you can comment on or make changes to this bug.