get rid of obsolete {Append,Assign}WithConversion

RESOLVED DUPLICATE of bug 113234

Status

()

Core
XPCOM
RESOLVED DUPLICATE of bug 113234
12 years ago
6 years ago

People

(Reporter: Jungshik Shin, Unassigned)

Tracking

({intl})

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
Getting rid of obsolete {Append,Assign}WithConversion and reviewing their call-sites would fix some I18N bugs (e.g. bug 328643) as well as giving us other benefits their successors are supposed to offer.
I have a question for ns*String. That is why there is not nsUTF8String. We need to read around code for that having nsCString is ASCII (or Native) or UTF8. If we have nsUTF8String class, its *WithConversion can treat the param as UTF8 string always.

Comment 2

12 years ago
I think the short story is that we ran out of time before Mozilla 1.0 had to ship, and we decided that we needed a frozen string story for Mozilla 1.0.  It was decided that ACString and AUTF8String would both map to nsACString in C++.
given the history *WithConversion has, I think it's a mistake to now use it for a non-lossy conversion... maybe we could just use Assign for utf8<->utf16 conversion if we had an nsUTF8String.

how does this bug differ from bug 113234?

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 113234
You need to log in before you can comment on or make changes to this bug.