setting "Local Folders->INBOX" as the inbox for a POP3 account disables downloading new mail

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
13 years ago
7 years ago

People

(Reporter: a_geek, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060203 MultiZilla/1.8.1.0p SeaMonkey/1.5a Mnenhy/0.7.3.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060203 MultiZilla/1.8.1.0p SeaMonkey/1.5a Mnenhy/0.7.3.0

Hello,
when I have the account settings in a POP3 account set to download to the INBOX of Local Folders, downloading new mail stops after a few days and does not resume after. Ie, selecting the Local Folders->Inbox and then pressing the download button does nothing (SeaMonkey 1.0 German zipfile from kairo.at on WinXP).
Resetting the link in the Account Settings-> Server -> Advanced back to
"INBOX for this account" brings things back to normal, and messages are
downloaded again.

Reproducible: Didn't try

Steps to Reproduce:
1. Create one account for POP3 email
2. Link this account's inbox to the inbox of "Local Folders"
3. use for a few days at most - then downloading new messages stops

Actual Results:  
Pressing the "download new messages" button is a NOP (no server contact could be observed).

Expected Results:  
New messages should be downloaded and sorted into the selected folder.

The flags for automatic download on startup and periodic
checks are disabled. The user has imported OE mail, address book and
appointments into Local Folders (creating a subtree starting with
something along the lines of "Imported OE mail".

While these inboxes are linked, the "real" account which holds
the information about the POP3 server is invisible in the accounts
pane to the left. Unlinking the inboxes makes it appear again.

Perhaps linking folders this way should be disabled altogether.
I think this is a big usability problem for low-tech users.
Can you reproduce with SeaMonkey v2.0a1pre ?
Version: unspecified → Trunk
(Reporter)

Comment 2

11 years ago
I can probably try that, but it will take me a few weeks to do so since I first need to prepare a suitable Windows box, along with the mailboxen, and because I am currently _severly_ time-strapped.
Mozilla/5.0 (X11; Linux i686; rv:2.0b8pre) Gecko/20101207 Firefox/4.0b8pre SeaMonkey/2.1b2pre - Build ID: 20101207033857

Global Inbox (Inbox on Local Folders) works for me, even on POP accounts.

Anyone still seeing this on Sm 2.0b2pre nightlies? If yes, speak up. If no one does, this bug will be RESOLVED WORKSFORME after the end of January.
Whiteboard: [CLOSEME 2011-02-01 WFM]

Comment 4

7 years ago
I close this bug, see Comment #3  --> Resolved.Worksforme
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Whiteboard: [CLOSEME 2011-02-01 WFM]
You need to log in before you can comment on or make changes to this bug.