Bug Already Marked Duplicate Error should linkify "This bug" and any other bug numbers

RESOLVED WONTFIX

Status

()

Bugzilla
User Interface
--
minor
RESOLVED WONTFIX
13 years ago
12 years ago

People

(Reporter: timeless, Assigned: timeless)

Tracking

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

13 years ago
actual results:
 This bug has already been marked as a duplicate of bug 325761.  

This bug eh? what bug is that?

steps to reproduce are somewhere in this rant:
i got this stupid message because of a stupid postdata has been lost dialog from my stupid browser. going back isn't working for me, and the only number listed isn't even the one i need and isn't a link.

expected results:
a. error message about this bug should
 1. list the number for "this bug"
 2. link to it!
b. link to any other bugs it references by number
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: This bug has already been marked as a duplicate of bug 325761. → bug already been marked as a duplicate error doesn't reference the bug the error applies to
Summary: bug already been marked as a duplicate error doesn't reference the bug the error applies to → bug already marked as a duplicate error doesn't reference the bug the error applies to

Updated

13 years ago
Severity: normal → minor
OS: MacOS X → All
Hardware: Macintosh → All
Summary: bug already marked as a duplicate error doesn't reference the bug the error applies to → Bug Already Marked Duplicate Error should linkify "This bug" and any other bug numbers
(Assignee)

Comment 1

13 years ago
Created attachment 214060 [details] [diff] [review]
change This bug and linkify both references
Assignee: ui → timeless
Status: NEW → ASSIGNED
Attachment #214060 - Flags: review?(LpSolit)

Comment 2

13 years ago
Comment on attachment 214060 [details] [diff] [review]
change This bug and linkify both references


>   [% ELSIF error == "dupe_entry_found" %]
>     [% title = "Already marked as duplicate" %]
>+    [% terms.Bug %]# <a href="show_bug.cgi?id=[% bug_id FILTER none %]">
>+    [% bug_id FILTER none %]</a> has already been marked as a
>+    duplicate of [% terms.bug %]
>+    <a href="show_bug.cgi?id=[% dupe_of FILTER html %]">
>+    [% dupe_of FILTER html %]</a>.

Use FILTER bug_link() to linkify bug numbers. And please no '#', this makes the UI ugly IMHO.
Attachment #214060 - Flags: review?(LpSolit) → review-
(Assignee)

Comment 3

13 years ago
Created attachment 214134 [details] [diff] [review]
use bug_link
Attachment #214060 - Attachment is obsolete: true
Attachment #214134 - Flags: review?(LpSolit)

Comment 4

12 years ago
WONTFIX on tip due to bug 92515. So this patch would be for 2.22 only.

Comment 5

12 years ago
Comment on attachment 214134 [details] [diff] [review]
use bug_link

This patch will not be taken on the 2.22 branch, and dupe_entry_found no longer exists on tip. => WONTFIX

(20:30:54) LpSolit: justdave: is bug 328801 something you would accept for 2.22?
(20:31:17) justdave: ehhhh
(20:31:24) justdave: I hate making cosmetic changes on branches
(20:31:33) LpSolit: that's what I thought too :)
Attachment #214134 - Flags: review?(LpSolit)

Comment 6

12 years ago
WONTFIX per comments 4 and 5.
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.