Access to FTP site crashes Firefox [@ xpcom_core.dll] [@ nsEscapeHTML]

VERIFIED FIXED

Status

--
critical
VERIFIED FIXED
13 years ago
3 months ago

People

(Reporter: jmjjeffery, Assigned: bryner)

Tracking

({crash, fixed1.8.1, regression})

2.0 Branch
x86
Windows XP
crash, fixed1.8.1, regression

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20060227 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20060227 Firefox/1.5

Access the URL and note the crash to the build created: 20060228
No TB is created




Reproducible: Always

Steps to Reproduce:
1. Access the URL
2.
3.

Actual Results:  
Crash of browser with no TB created

Expected Results:  
Site should load.
Crash also using SafeMode.

Sorry for double entry.
Keywords: crash, regression
Status: UNCONFIRMED → NEW
Ever confirmed: true
TB15737215H
TB15737194Z

1. New profile, start firefox
2. Navigate to ftp.mozilla.org
3. CRASH!
Summary: Access to FTP site crashes Firefox → Access to FTP site crashes Firefox [@ xpcom_core.dll]
Version: unspecified → 2.0 Branch
Summary: Access to FTP site crashes Firefox [@ xpcom_core.dll] → Access to FTP site crashes Firefox [@ xpcom_core.dll]
Component: General → XPCOM
Product: Firefox → Core
QA Contact: general → xpcom
Version: 2.0 Branch → 1.8 Branch
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060227 Firefox/1.6a1 ID:2006022802

No problem with trunk
Component: XPCOM → Build Config
Product: Core → Firefox
Version: 1.8 Branch → 2.0 Branch

Comment 6

13 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20060228 Firefox/1.5

Crash on Linux as well
Flags: blocking-firefox2?
*** Bug 328888 has been marked as a duplicate of this bug. ***

Comment 8

13 years ago
talkback appears to be unusable, we need to reproduce in a debug build and get a useful stack.
Given the stack in bug 328888, this might have been caused by bug 328755.

Comment 10

13 years ago
I'm adding the talkback symbols I get in the crash to make it easier to find this bug in the summary. I was searching on nsEscapeHTML not xpcom_core. Sorry for the dupe. 

Incident ID 15751163 has some stack information but its suspect as the installer left me with a 02/27 app binary but a version of talkback for 02/14 (I filed a bug on that already). But at least you can see the call into xpcom_core: nsEscapeHTML.
Summary: Access to FTP site crashes Firefox [@ xpcom_core.dll] → Access to FTP site crashes Firefox [@ xpcom_core.dll] [@ nsEscapeHTML]

Comment 11

13 years ago
-> bryner for investigation
Assignee: nobody → bryner
(Assignee)

Comment 12

13 years ago
fixed by backout of bug 328755.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED

Comment 13

13 years ago
*** Bug 328965 has been marked as a duplicate of this bug. ***
Flags: blocking-firefox2?

Comment 14

13 years ago
I've verified that ftp urls are now loading again on the 1.8.1 branch with builds from 03/01. Thanks Brian. 
Status: RESOLVED → VERIFIED
Crash Signature: [@ xpcom_core.dll] [@ nsEscapeHTML]
Component: Build Config → General
Product: Firefox → Firefox Build System
You need to log in before you can comment on or make changes to this bug.