yahoo.com - MyYahoo drag-and-drop reordering of content doesn't work in Camino (works in Fx)

VERIFIED WORKSFORME

Status

Tech Evangelism Graveyard
English US
VERIFIED WORKSFORME
12 years ago
3 years ago

People

(Reporter: Jamie Cho, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060214 Camino/1.0
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060214 Camino/1.0

When configured with certain items, MyYahoo.com supports drag and drop reordering of certain content. For example, my yahoo page has three news sections which are currently in this order:
1. Reuters Top Stories
2. Full Coverage
3. Boston (WCVB)

In FireFox, I can change the order to (say) Boston, Reuters, Full Coverage by merely dragging the title frame of Boston and moving it above Reuters.

In Camino, however, what happens is that text gets selected instead.

Reproducible: Always

Steps to Reproduce:
1. Setup a myyahoo page with items of similar content (such as Reuters Top Stories, Full Coverage, Boston)
2. Login to the myyahoo page
3. Try to drag content arround by clicking on the title bar
Actual Results:  
The entire content box should drag with the mouse movement.

Expected Results:  
Text got selected instead.

Trying to reproduce the problem by saving the content to HTML complete breaks the Java script behavior and causes the text selection even in FireFox. Thus, this must be tested online.
-> TE

Works if you spoof UA as Firefox; you should contact Yahoo and tell them to serve the same JavaScript to Camino as they serve to Firefox.

This is getting really annoying with Yahoo. :-(
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: MyYahoo Drag And Drop Reordering Of Content Does Not Work → yahoo.com - MyYahoo drag-and-drop reordering of content doesn't work in Camino (works in Fx)
Er, really kicking to TE now....
Component: Drag & Drop → English US
Product: Camino → Tech Evangelism
Grr, 3rd time's the charm.  Sorry.
Assignee: mikepinkerton → english-us
QA Contact: english-us
Blocks: 334967

Comment 4

12 years ago
Reported to My Yahoo.
Still a problem when spoofing as Camino 1.5; works in Firefox 2.0.0.3.

Gerv

Comment 6

10 years ago
Is this still a problem with the latest changes to My Yahoo?
Problem not found
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME

Comment 8

4 years ago
Hallvord, I'm going to assume that you read the summary and the bug and did your due diligence to test this bug in Camino not in Firefox, or at least using Firefox with a non-Firefox user agent. As skeptical as I am, I can't imagine any other reason for a MoCo employee to pop in and close a bug unrelated to Firefox. Maybe you just care more than others.

I took a minute to re-test using the last (final) version of Camino, and the problem is indeed gone. I then tested in the latest Firefox using a spoofed user agent and the problem didn't appear there either.

v.WORKSFORME
Status: RESOLVED → VERIFIED
I did test with a Camino user agent (although in a stock Firefox beta), and will make sure to include in the resolution what UA setting I've used for the testing from now on. Thanks for verifying!
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.