Empty <table> causes "ASSERTION: Must only be called on reflowed lines"

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
13 years ago
12 years ago

People

(Reporter: jruderman, Assigned: roc)

Tracking

(Blocks 1 bug, {assertion, testcase})

Trunk
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Reporter

Description

13 years ago
An empty <table> causes:

###!!! ASSERTION: Must only be called on reflowed lines: '!(GetStateBits() & NS_FRAME_IS_DIRTY)', file /Users/admin/trunk/mozilla/layout/generic/nsFrame.cpp, line 3534
Reporter

Comment 1

13 years ago
Posted file testcase
Reporter

Updated

13 years ago
This is probably a regression introduced sometime in the last 7 days. My debug build from 20060223 did not show this assertion, now i rebuilt and i see the assertion, too (Win2k, SeaMonkey trunk).
OS: MacOS X → All
Hardware: Macintosh → All
Ok, ignore me, this assertion is new in code, so of course no regression...
Reporter

Comment 4

13 years ago
CCing roc since he added this assertion.
Blocks: 256311
Posted patch fixSplinter Review
We call CachedIsEmpty from PlaceBlock() ... the frame has been reflowed, but it's still marked dirty because we haven't determined its final position and called FinishReflowChild on it yet. Mark it dirty early to indicate that it really is OK.
Assignee: nobody → roc
Status: NEW → ASSIGNED
Attachment #213849 - Flags: superreview?(dbaron)
Attachment #213849 - Flags: review?(dbaron)
Comment on attachment 213849 [details] [diff] [review]
fix

This scares me a little, especially since I'm checking this bit more on the reflow branch, but I suppose this should be ok.
Attachment #213849 - Flags: superreview?(dbaron)
Attachment #213849 - Flags: superreview+
Attachment #213849 - Flags: review?(dbaron)
Attachment #213849 - Flags: review+
checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Reporter

Comment 8

12 years ago
Crashtest checked in.
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.