Case sensitivity and CodeWarriorLib.pm

RESOLVED FIXED

Status

P3
normal
RESOLVED FIXED
19 years ago
14 years ago

People

(Reporter: jlong, Assigned: jj.enser)

Tracking

Trunk
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
To reproduce:
In using the CodeWarriorLib.pm on Macintosh, give the full name for the project 
to build with case that does not match the Macintosh OS's display in the 
finder. eg.: 
CodeWarriorLib::build_project("MyHD:tHiS:isThe:wronG:capS:foo.mCp",$target,$outp
ut,$clean);
Result:
The project will fail to build. 

Expected:
Since the Mac OS is case insensitive, the project should build even if the case 
does not match.

How to fix:
In CodeWarriorLib.pm change:
Line 74:                     if ($full_path eq _full_path($cp)) {
 to
Line 74:                    if (lc $full_path eq lc _full_path($cp)) {
and an identical fix for line 79.

Comment 1

19 years ago
Mac.
Assignee: cls → jj
Target Milestone: ---
(Assignee)

Comment 2

19 years ago
Simon, Steve, I know this is low priority, but do you approve this change?

Comment 3

19 years ago
Sounds good to me.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 4

19 years ago
Fixed.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Updated

14 years ago
OS: Mac System 9.x
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.