If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

image tag does not display image from local server.

RESOLVED INVALID

Status

()

Firefox
General
--
major
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: wolffy, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

If the image is on a file server "//fileserver/foldername/image.jpg"  the <img src="//fileserver/foldername/image.jpg"> does not work and displays a broken image. This feature works in IE and Netscape.

I have noticed some web sites where the images do not show in Fire Fox, I believe this is most likely the reason why. I will add comments to this when I find some public examples.

Reproducible: Always

Steps to Reproduce:
1.create a image tag <img scr="\\fileserver\folder\filename.jpg">
2.view it in IE, then in Fire Fox.
3.Scream and swear!

Actual Results:  
Blood pressure rises!

Expected Results:  
viewable image.

display image in html.
INVALID as per bug 286415.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID

Comment 2

12 years ago
If you open a web page through the HTTP protocol, you cannot link to local content with the default security settings.  Moreover, links to local content should start with file:// and use forward slashes as the path delimiter.  Windows-style paths are incorrect.

See http://kb.mozillazine.org/Links_to_local_pages_don't_work for more details.
You need to log in before you can comment on or make changes to this bug.