Emoticons are not converted to graphics in HTML mail

VERIFIED INVALID

Status

MailNews Core
Backend
P3
normal
VERIFIED INVALID
19 years ago
10 years ago

People

(Reporter: marina, Assigned: selmer (gone))

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
**** observed with 2000-03-22 Beta1 build ****
Steps to reproduce:
-check Convert Emoticons to graphics under Edit|Preferences|Message;
-compose a message with :-);
-send message and get it;
//now note: if the mail settings are HTML compose there is no convertion done
(only if you send Plain text mail)

Comment 1

19 years ago
*** Bug 32907 has been marked as a duplicate of this bug. ***

Comment 2

19 years ago
*** Bug 32910 has been marked as a duplicate of this bug. ***

Comment 3

19 years ago
*** Bug 32912 has been marked as a duplicate of this bug. ***

Comment 4

19 years ago
I believe the emoticon and html attributes for structured phrases are only
supposed to work in plain text.  Will double-check to make sure.
QA Contact: lchiang → laurel
Summary: Emoticons are not converted to graphics in HTML mail → Emoticons are not converted to graphics in HTML mail
Target Milestone: ---
(Reporter)

Comment 5

19 years ago
bugzilla was down when i was posting and we've got two dups this way :-)
(Reporter)

Comment 6

19 years ago
In IM window settins are obviously HTML ones and it is working there...

Comment 7

19 years ago
I checked with Rich Pizzarro, the in-house developer who worked on the emoticon
conversion stuff for mail.  He told me it is only intended for plain text
enhancement, not applicable to html.  
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → INVALID
(Reporter)

Comment 8

19 years ago
how come it is working in Instant Messenger where setting are HTML?

Comment 9

19 years ago
IM is different code.  Emoticons only get converted / show up as smiley face
icons for plain text.  This was added in by Ben B.  This has nothing to do with IM.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 10

19 years ago
I understand it's a different code but what about integration, shouldn't we have  
same functionality?
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.