[BeOS] Places toolbar does not show bookmarks

RESOLVED WORKSFORME

Status

()

P1
critical
RESOLVED WORKSFORME
13 years ago
9 years ago

People

(Reporter: doug, Assigned: bugs)

Tracking

unspecified
Firefox 2 alpha1
x86
BeOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (BeOS; U; BeOS BePC; en-US; rv:1.9a1) Gecko/20060225 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (BeOS; U; BeOS BePC; en-US; rv:1.9a1) Gecko/20060225 Firefox/1.6a1

Places toolbar displays places icon but no bookmarks.  This used to work (when places was first enabled).  I tried running --profilemanager and creating a clean profile but still no luck.

Reproducible: Always

Steps to Reproduce:
1.Start Firefox
2.display places toolbar
3.observe lack of bookmarks on toolbar

Actual Results:  
no bookmarks on toolbar

Expected Results:  
bookmarks and icons should show on toolbar
(Reporter)

Comment 1

13 years ago
Created attachment 213870 [details]
screenshot of browser with missing bookmarks
See Bug 329100 and 328299.
(Reporter)

Comment 3

13 years ago
(In reply to comment #2)
> See Bug 329100 and 328299.
> 
Comment in 329100 implies carryover of .rdf from previous build.  In this instance, I see the same behavior even when creating a new profile, so maybe this is a different variation on the problem.
(Reporter)

Comment 4

13 years ago
I'm working with a debug build.  I started Firefox and saw a javascript error as the main window opened.  Clicking on the places toolbar generated a javascript error with each click.  I hope this helps:
++DOMWINDOW == 5
Note: verifyreflow is disabled
++DOMWINDOW == 6
JavaScript error: , line 0: uncaught exception: [Exception... "Component returned failure code: 0x80004002 (NS_NOINTERFACE) [nsIDocShellHistory.useGlobalHistory]"  nsresult: "0x80004002 (NS_NOINTERFACE)"  location: "JS frame :: chrome://browser/content/browser.js :: prepareForStartup :: line 721"  data: no]
WARNING: NS_ENSURE_TRUE(NS_SUCCEEDED(rv)) failed: file /boot/home/develop/mozilla/toolkit/components/history/src/nsGlobalHistory.cpp, line 2627
WARNING: NS_ENSURE_TRUE(NS_SUCCEEDED(rv)) failed: file /boot/home/develop/mozilla/toolkit/components/history/src/nsGlobalHistory.cpp, line 2627
JavaScript error: chrome://browser/content/places/toolbar.xml, line 645: this.getResult() has no properties
JavaScript error: chrome://browser/content/places/toolbar.xml, line 645: this.getResult() has no properties
JavaScript error: chrome://browser/content/places/toolbar.xml, line 645: this.getResult() has no properties
JavaScript error: chrome://browser/content/places/toolbar.xml, line 645: this.getResult() has no properties
                                                                                                              
Assignee: nobody → bugs
Severity: major → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P1
Target Milestone: --- → Firefox 2 alpha1

Comment 5

13 years ago
Something is messed up with your build, nsGlobalHistory.cpp shouldn't be getting compiled at all. In toolkit/components/ is has a condition on MOZ_PLACES for the 'src' directory. Either this somehow doesn't work for BeOS or your build needs cleaning.

Comment 6

13 years ago
I meant toolkit/components/history/Makefile.in in the previous post.
(Reporter)

Comment 7

13 years ago
(In reply to comment #6)
> I meant toolkit/components/history/Makefile.in in the previous post.
> 
It looks like the flag is present in this file.  I shall completely delete my output directory and rebuild.  We'll see if that fixes it, else we may have another BeOS gremlin.

(Reporter)

Comment 8

13 years ago
deleting output directory, rebuilding then starting with a clean profile fixed this problem, so there was definitely a build issue.  However, starting with my existing profile, items are still missing.  Further, the "file/import" option did not import bookmarks from my other profile, either.  Suggestions?

Comment 9

13 years ago
I filed bug 329343 for the File|Import menu needing to be hooked up with places.
(Reporter)

Updated

13 years ago
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.