Status

()

Firefox
General
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: Wouter Beek, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20051010 Firefox/1.0.7 (Ubuntu package 1.0.7)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20051010 Firefox/1.0.7 (Ubuntu package 1.0.7)

I have just set up my own MediaWiki site and the installation seemed to work perfectly for me. However when I press the reload button in my firefox browser the wiki Main_Page disappears and is replaced by a blank page (a completely blank page). The same thing happens whenever I press the top-left image (which points to the Main_Page). Using CRTL+SHIFT while pressing the refresh button does reload (and display) the main page correctly. This is however very unpractical. The same problem applies to all other pages in my wiki. Reinstalling the wiki gave the same result. My site works normally in InternetExplorer, Safari and Opera. All Gecko-based browsers and Konqueror do however show this problem.

Reproducible: Always

Steps to Reproduce:
1. Visit http://www.wouterbeek.com/index.php?title=Main_Page
2. Reload the page.
3.

Actual Results:  
The browser area in firefox goes blank. Even the backward button does not work! Only CTRL+SHIFT+reload works.

Expected Results:  
The page should be displayed inside the rendering area of firefox (just as it does in Safari and Opera).

Comment 1

13 years ago
works for me in Firefox 1.5
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

Comment 2

13 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20060110 Firefox/1.5

HTTP debug log of reload request:

http request [
  GET /index.php?title=Main_Page HTTP/1.1
  Host: www.wouterbeek.com
  User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20060110 Firefox/1.5
  Accept: text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5
  Accept-Language: en-us,en;q=0.5
  Accept-Encoding: gzip,deflate
  Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
  Keep-Alive: 300
  Connection: keep-alive
  If-Modified-Since: Fri, 03 Mar 2006 09:21:38 GMT
  If-None-Match: W/"isidorus:pcache:idhash:1-0!1!0!0!!en!2--20060303092138"
  Cache-Control: max-age=0
]

The server response for this request is:

http response [
  HTTP/1.1 200 OK
  Cache-Control: private, must-revalidate, max-age=0
  Content-Type: text/html
  Content-Encoding: gzip
  Expires: -1
  Last-Modified: Fri, 03 Mar 2006 09:21:38 GMT
  Etag: W/"isidorus:pcache:idhash:1-0!1!0!0!!en!2--20060303092138"
  Vary: Accept-Encoding
  Server: Microsoft-IIS/6.0
  X-Powered-By: PHP/4.3.11, ASP.NET
  Date: Fri, 03 Mar 2006 09:52:59 GMT
  Connection: close
]

The actual content returned by the server for this request is empty, however:

waiting for the server to close the connection.
nsHttpTransaction::HandleContent [this=9218f60 count=0 read=0 mContentRead=0 mContentLength=-1]

A simple test with wget shows that the server reply is empty when the "If-Modified-Since:" header is present in the request, so this is clearly a server problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
*** Bug 329322 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.