When "makeproductgroup" is selected, error occurs when creating a product

RESOLVED DUPLICATE of bug 305927

Status

()

RESOLVED DUPLICATE of bug 305927
13 years ago
13 years ago

People

(Reporter: mb, Unassigned)

Tracking

2.20
x86
Windows XP

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

When "makeproductgroup" is selected in editparams.cgi and a product is created, I get the following error message:

Adding new product
Software error:
DBD::mysql::st execute failed: Field 'userregexp' doesn't have a default 
value [for Statement "INSERT INTO groups (name, description, isbuggroup, 
last_changed) VALUES ('test', 'Access to bugs in the test product', 1, 
NOW())"] at Bugzilla/DB.pm line 84
Bugzilla::DB::SendSQL('INSERT INTO groups (name, description, isbuggroup, 
last_chang...') called at C:\bugzilla\editproducts.cgi line 559
For help, please send mail to this site's webmaster, giving this error 
message and the time and date of the error.

[Thu Mar 2 15:15:57 2006] editproducts.cgi: DBD::mysql::st execute failed: 
Field 'userregexp' doesn't have a default value [for Statement "INSERT INTO 
groups (name, description, isbuggroup, last_changed) VALUES ('test', 'Access 
to bugs in the test product', 1, NOW())"] at Bugzilla/DB.pm line 84 [Thu Mar 
2 15:15:57 2006] editproducts.cgi: Bugzilla::DB::SendSQL('INSERT INTO groups 
(name, description, isbuggroup, last_chang...') called at 
C:\bugzilla\editproducts.cgi line 559



However, I fixed the problem, see information below.


Reproducible: Always

Steps to Reproduce:
1. select "makeproductgroup" in the parameters-page
2. create a new product


Actual Results:  
I got the error message from above, the product was created though, but not the group.

Expected Results:  
No error message

The proble is: the table "groups" in the mysql-db has no default value for "userregexp". So I put this in the file "editproducts.cgi" at line 559:

SendSQL("INSERT INTO groups " .
                "(name, description, isbuggroup, last_changed, userregexp) " .
                "VALUES (" .
                SqlQuote($productgroup) . ", " .
                SqlQuote("Access to bugs in the $product product") . ", 1, NOW()," . 
		    SqlQuote(" ") . ")");
(Reporter)

Updated

13 years ago
Version: unspecified → 2.20
(Reporter)

Updated

13 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Updated

13 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 305927 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE

Comment 2

13 years ago
I don't know which version of MySQL you are using, but MySQL uses '' by default when the default value is missing. We only reached to reproduce the bug on PostgreSQL.
(Reporter)

Comment 3

13 years ago
(In reply to comment #2)
> I don't know which version of MySQL you are using, but MySQL uses '' by default
> when the default value is missing. We only reached to reproduce the bug on
> PostgreSQL.
> 

Hi, 
I use MySql version 5.0
You need to log in before you can comment on or make changes to this bug.