If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Show/hide toolbars does not trigger window.resize

RESOLVED WORKSFORME

Status

()

Firefox
Toolbars and Customization
RESOLVED WORKSFORME
12 years ago
9 years ago

People

(Reporter: JulianC, Unassigned)

Tracking

1.5.0.x Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2009-02-04], URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

Sites that use the window.onresize event to resize their contents can be broken when showing or hiding Firefox's toolbars. 

Reproducible: Always

Steps to Reproduce:
1. Press Ctrl-F
2. Navigate to www.Lst.ac.uk
3. Close the find bar (or hide any other optional toolbar).

Actual Results:  
You will see that the bottom two <div> areas are not resized to fill the empty space, wheras they are if you change the window size in some other way.

Expected Results:  
Shouldn't window.onresize be triggered whenever the available document space changes size? Or is there a different onresize event that this website should be using instead of window.onresize?

Updated

12 years ago
Component: Find Toolbar / FastFind → Toolbars

Updated

12 years ago
QA Contact: fast.find → toolbars
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060228 Firefox/1.6a1 ID:2006022815
I see this too.

Comment 2

9 years ago
WFM (using the javascript: URL I added) on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090103 Shiretoko/3.1b3pre. Can you reproduce this on a recent build?

(I don't see anything resizing on www.Lst.ac.uk -- probably the site got redesigned?)
Whiteboard: [closeme 2009-02-04]
Version: unspecified → 1.5.0.x Branch

Comment 3

9 years ago
A similar bug on Linux, filed for 3.0b5: bug 429051.
The testcase javascript:void(onresize=alert) works for me,
Firefox 3.0.8pre (2009022204) on Linux.

-> WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.