Select with duplicate option values shows wrong selection on refresh for all selects

RESOLVED DUPLICATE of bug 201056

Status

()

Core
Document Navigation
RESOLVED DUPLICATE of bug 201056
13 years ago
10 years ago

People

(Reporter: David Tiller, Unassigned)

Tracking

({testcase})

1.8 Branch
x86
Windows XP
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

The value chosen in all select input boxes changes when you hit refresh and there are options with the same value but different display strings.

For example, selects sel0, sel1, and sel2 have the same option lists. Each list has 2 or more entries with the same value, but a different display string. When refreshing the page, all selects display the string for the last-defined option with the duplicate value.

THIS ALSO HAPPENS under OSX with FireFox 1.5.0.1.

Reproducible: Always

Steps to Reproduce:
1. Open the attached HTML document.
2. Note that the default 'Select...' displays.
3. Hit the refresh button.
4. Note that the selected value changes to 'View Details 1'.

Actual Results:  
Selected value changes to the last defined duplicate option value.

Expected Results:  
Selected value should remain the same.
(Reporter)

Comment 1

13 years ago
Created attachment 213925 [details]
HTML Test Case

This is the HTML document that reveals the bug.

Updated

13 years ago
Keywords: testcase
Dupe of bug 46845?
(Reporter)

Comment 3

13 years ago
(In reply to comment #2)
> Dupe of bug 46845?
> 

I would say no. That case deals with keeping/discarding changes to a from on reload. This case deals with the default option shown in a select box without there being any changes to the form. The initial load is different from the reload. This only manifests itself when there are duplicate values in a select box's options.
Component: Form Manager → History: Session
Product: Firefox → Core
QA Contact: form.manager → history.session
Version: unspecified → 1.8 Branch

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 201056

Updated

10 years ago
Component: History: Session → Document Navigation
QA Contact: history.session → docshell
You need to log in before you can comment on or make changes to this bug.