Address Book: Clicking onto a blank column resorts

VERIFIED FIXED in Future

Status

P3
normal
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: nbaca, Assigned: sspitzer)

Tracking

Trunk
Future
All
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Build 2000-03-22-11M15trunk: Win95
Build 2000-03-22-08M15trunk: Linux 6.0, Mac 8.5.1

Overview: Clicking on the "Organization" column changes the sort, even when 
there are no entries in the Organization column.

Steps to reproduce:
1. Create an Address Book where each address book card leaves the "Organization" 
field blank.
2. Click onto the Organization column

Actual Results: Notice that the address book entries are resorted but I'm not 
sure in what order.

Expected Results: It doesn't make sense to be able to sort on a column that 
doesn't have any entries. What should the behavior be?
(Reporter)

Updated

19 years ago
QA Contact: lchiang → esther
Target Milestone: ---

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → M16

Comment 1

19 years ago
Not beta2 stopper.  Marking M18.  Please let me know if you disagree.
Target Milestone: M16 → M18

Comment 2

19 years ago
Mass move mailnews bugs to Putterman.  Ouch.
Assignee: hangas → putterman
Status: ASSIGNED → NEW

Comment 3

19 years ago
luis - can you see if this is still a problem in the latest Windows build?

Comment 4

19 years ago
Using 7-7-21-M17 build: still a problem.

Comment 5

19 years ago
moving to future milestone.
Target Milestone: M18 → Future

Comment 6

18 years ago
Changing qa assign to myself.
QA Contact: esther → pmock

Comment 7

18 years ago
reassigning to chuang.
Assignee: putterman → chuang

Comment 8

18 years ago
Assign it to myself.
QA Contact: pmock → fenella

Updated

18 years ago
Keywords: nsCatFood

Updated

18 years ago
QA Contact: fenella → nbaca

Comment 9

18 years ago
reassigning to racham.
Assignee: chuang → racham
taking, this is fixed with the AB_OUTLINER_BRANCH.

the secondary sort column is now email.  so if you were to click on a column
that had all blank, it would sort by email.
Assignee: racham → sspitzer
fixed.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 12

17 years ago
Trunk build 2002-01-28-03: WinMe
Trunk build 2002-01-28-08: Linux RH 7.1
Trunk build 2002-01-28-08: Mac 10.1
Verified Fixed, clicking on a blank column resorts the email column. 

Although I'm wondering why it performs the secondary sort since I'm clicking on 
a blank column.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.