When one BUTTON is clicked multiple visual feedback is given

VERIFIED FIXED

Status

()

P3
normal
VERIFIED FIXED
20 years ago
20 years ago

People

(Reporter: cpratt, Assigned: eric)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
Sample HTML code is:

<form action="mailto:Kligor.T@gee.whiz.com">
	<p>The following line contains a button.
	<p>
	<button>
		This is some text that goes on the button.
	</button>
	<p>The following line contains a button that has an image on it.
	<p>
	<button>
		Click here<br>
		<img src="logo-star.gif" alt="The Mozilla logo"><br>
		to send us feedback!
	</button>
	<p>Clicking either button will submit this form. The button should give
proper visual feedback.
</form>

This creates a form with two BUTTON elements. When either BUTTON is clicked,
visual feedback is produced which shows both BUTTONs depressing.

This may of course be by design - neither of these BUTTONs have an explicit
name - but in terms of user experience, I'm guessing that we would ideally just
show one button depressing when one button is clicked, as MSIE 4.01 does.
German?

Updated

20 years ago
Assignee: troy → karnaze

Updated

20 years ago
Assignee: karnaze → evaughan
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED

Updated

20 years ago
QA Contact: 4110 → 4137

Comment 1

20 years ago
Reassigning QA contact to cpratt@netscape.com (FORM related)
(Assignee)

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED
(Reporter)

Comment 2

20 years ago
The March 5 build gives no visual feedback when BUTTONs are pressed, so I can't
regress this at the moment. Will put off until later.
(Reporter)

Updated

20 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

20 years ago
Works OK. Still have a problem with the thin grey line persisting after onBlur.
Verified fixed in 09-March build.
You need to log in before you can comment on or make changes to this bug.