With multiple POP accounts, settings can only be accessed for one

RESOLVED DUPLICATE of bug 327473

Status

MailNews Core
Backend
--
major
RESOLVED DUPLICATE of bug 327473
12 years ago
10 years ago

People

(Reporter: Ian Neal, Unassigned)

Tracking

({regression})

Trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
Using builds since BuildID 2006020408 when you multiple POP accounts defined in both Thunderbird and SeaMonkey you can only access/alter account settings for one of the POP accounts.

Steps to reproduce
1. Start with a new profile
2. Create first POP account:
  a) Select Email account
  b) Enter "Fred" in Your Name and "fred@abc.com" in Email Address
  c) Set Incoming Server to "pop1" and Outgoing Server to "smtp" - keep Global Inbox unchecked
  d) Leave Incoming/Outgoing User Names as "fred"
  e) Leave Account Name as "fred@abc.com"
  f) Uncheck "Download messages now"
  g) Click Finish button
3. Go into Account Settings Window
4. Check "fred@abc.com" tree is expanded
5. Click on Add Account button to add second account
  a) Select Email account
  b) Enter "Joe" in Your Name and "joe@xyz.org" in Email Address
  c) Set Incoming Server to "pop2" - keep Global Inbox unchecked
  d) Leave Incoming User Name as "joe"
  e) Leave Account Name as "joe@xyz.org"
  f) Click Finish button
6. Look at listed accounts

Expected results
1. Both account trees can be expanded contracted

Actual results
1. First account tree "fred@abc.com" is expandable/contractable but second "joe@xyz.org" is not and only the main settings panel can be accessed.
2. Closing and reopening Account Settings reserves the above, i.e. First account tree "fred@abc.com" is not expandable/contractable with only the main settings panel accessible and the second "joe@xyz.org" is fully expandable/contractable.

For Thunderbird regression window is between BuildIDs 2006021305 and 2006021405
For SeaMonkey regression window is between BuildIDs 2006021315 and 2006021408
(Reporter)

Comment 1

12 years ago
Of course I meant reverses not reserves in the comment above
(Reporter)

Comment 2

12 years ago
I've checked both branches and this bug is not present on either
(Reporter)

Comment 3

12 years ago
ah, also mistyped the original BuildID, should have read BuildID 2006021408 instead of 2006020408

Comment 4

12 years ago
dupe of "[TB/SM] Account Settings not accessible if more then one account"

*** This bug has been marked as a duplicate of 327473 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.