Typing "http" as the url takes you to microsoft.com rather than http.com

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: t35t0r t35t0r, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.8) Gecko/20051111 Firefox/1.5

Typing "http" as the url takes you to microsoft.com rather than http.com . Was this done intentionally? This is not what it does in mozilla or opera. The same thing happens if you accidentally type "http//somelongstring" (note that there is no ':' after the "http"). 

Reproducible: Always

Steps to Reproduce:
1. type "http" in the url bar and hit enter


Actual Results:  
goes to microsoft.com

Expected Results:  
should go to http.com
This is because it's not a valid URI, and so Firefox is treating it as a search term; if you go to Google and type "http" then click "I'm feeling lucky", you'll be taken to Microsoft's website too.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID

Comment 2

12 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060316 Firefox/1.6a1

This is a Dup of Bug 263213 "Don't use I'm Feeling Lucky search when protocol 
(such as http:// or https://) specified".

Incredibly, there are about 30 variants of this problem, my favourite being Bug 310826 "Attempting to load URL with non-resolving host does google search 
(using keyword.url) even when the URL was not typed by the user"

Using the "I'm Feeling Lucky" search in this case is considered by some 
probably including yourself, to be contentious; but yes, it is being done 
intentionally. If you think that Opera handles "empty" URLs such as

http
http:
http//

better, then you might want to locate the bug that deals with that
particular variant and ask for parity with Opera, which to me seems a
perfectly valid request!
You need to log in before you can comment on or make changes to this bug.