Author profiles may contain homepage links without http:// - leads to problems

RESOLVED FIXED in 1.0

Status

addons.mozilla.org Graveyard
Public Pages
RESOLVED FIXED
12 years ago
2 years ago

People

(Reporter: AsherMaximum, Assigned: morgamic)

Tracking

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

the link on this mage for the developrs site says www.kaboodle.com, but actually goes to https://addons.mozilla.org/extensions/www.kaboodle.com (which obviously doesn't exist)

Reproducible: Always

Steps to Reproduce:
1.just go to bage ;listed and click on the link
2.
3.



Expected Results:  
should have gone to http;//www.kaboodle.com

Comment 1

12 years ago
Confirming.

Suspect this may be because the author did not include http:// 

Interestingly, on the extension page - https://addons.mozilla.org/extensions/moreinfo.php?application=firefox&id=1577 - the homepage link points at the correct url. 

Need to work our what the difference is in how this code is generated.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Version: unspecified → 1.0

Comment 2

12 years ago
Author's profile updated. 
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 3

12 years ago
Shouldn't we patch something so that it automatically includes the http:// and this doesn't happen in future? or so that the authorprofiles.php page generates the web address in the same way that moreinfo.php does?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Summary: bad link → Author profiles may contain homepage links without http:// - leads to problems

Comment 4

12 years ago
*** Bug 292760 has been marked as a duplicate of this bug. ***

Comment 5

12 years ago
Automatic http-ing now :)

*hugs v2*
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.