Editing properties of JavScript shell bookmarklet in bookmark manager causes freeze / lockup

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
13 years ago
10 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060126 SUSE/1.5.0.1-5.1 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060126 SUSE/1.5.0.1-5.1 Firefox/1.5.0.1

After bookmarking the JavaScript "Shell" bookmarklet provided at http://www.squarefree.com/bookmarklets/webdevel.html (which works fine), one can not edit the properties of said bookmark. Attemping to open the properties dialog in the bookmark-manager results in either
a) complete lock-up of Firefox or
b) sometimes the application even crashes.

This bug was only reproducible with the JS shell bookmarklet, but not with other bookmarklets from said website.

Reproducible: Always

Steps to Reproduce:
1. go to: http://www.squarefree.com/bookmarklets/webdevel.html
2. Bookmark the "shell" bookmarklet (bookmark method doesn't sem to matter)
3. Open bookmark-manager
4. locate "shell" bookmarklet
5. Attempt to open properties dialog for the bookmarklet

Actual Results:  
Firefox locks up completely, sometimes even crashes immediately.

Expected Results:  
The bookmarklet's properties dialog is shown.

My original goal was to assign a keyword to the bookmarklet, and in an attempt to work around this bug I tried to manually assign a keyword (SHORTCUTURL) to the bookmarklet by modifying bookmarks.html. However, when I try to use the bookmark keyword in the location-bar, Firefox crashes everytime. 

Also tested with an empty firefox profile, with same results.
Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9a1) Gecko/20060311 Firefox/1.6a1 ID:0000000000
Confirmed with places enabled. (Don't know how much of the attached output is related to the crash, but it's here anyway.)

WARNING: NS_ENSURE_TRUE(NS_SUCCEEDED(rv)) failed: file /home/philip/mozilla/netwerk/protocol/http/src/nsHttpChannel.cpp, line 1462
WARNING: cache check failed: file /home/philip/mozilla/netwerk/protocol/http/src/nsHttpChannel.cpp, line 391
JavaScript error: chrome://browser/content/browser.xul, line 1: BookmarksUtils is not defined
WARNING: NS_ENSURE_TRUE(NS_SUCCEEDED(rv)) failed: file /home/philip/mozilla/layout/style/nsCSSLoader.cpp, line 1912
WARNING: NS_ENSURE_TRUE(NS_SUCCEEDED(rv)) failed: file /home/philip/mozilla/intl/strres/src/nsStringBundle.cpp, line 273
CSS Error (chrome://browser/content/browser.xul :0.5): Error in parsing value for property 'max-width'.  Declaration dropped.
CSS Error (chrome://browser/content/browser.xul :0.5): Error in parsing value for property 'max-width'.  Declaration dropped.
CSS Error (chrome://browser/content/browser.xul :0.5): Error in parsing value for property 'max-width'.  Declaration dropped.
CSS Error (chrome://browser/content/browser.xul :0.5): Error in parsing value for property 'max-width'.  Declaration dropped.
WARNING: NS_ENSURE_TRUE(NS_SUCCEEDED(rv)) failed: file /home/philip/mozilla/editor/libeditor/base/nsEditor.cpp, line 1278
JavaScript error: chrome://browser/content/browser.xul, line 1: BookmarksUtils is not defined
WARNING: NS_ENSURE_TRUE(cv) failed: file /home/philip/mozilla/xpfe/appshell/src/nsXULWindow.cpp, line 1565
###!!! ASSERTION: nsIDOMChromeWindow::SetTitle is deprecated, use nsIDOMNSDocument instead: 'Error', file /home/philip/mozilla/dom/src/base/nsGlobalWindow.cpp, line 6918
The program 'Gecko' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadLength (poly request too large or internal Xlib length erro'.
  (Details: serial 625973 error_code 16 request_code 81 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Oddly, the bookmark also doesn't appear to be bookmarked if you right-click on it and try to bookmark it. However, dragging it to your bookmarks toolbar works.
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk
(Reporter)

Comment 2

12 years ago
Did a regression-test of this bug with a nightly build.
(Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060521 Minefield/3.0a1)

The following has changed:
- Fx no longer hangs or crashes at step 5, the properties dialog can now be opened.
- bookmarking the shell-bookmarklet via right-click does not work any more (see comment #1). (dragging it onto the bookmarks toolbar works)
- upon performing step 5, not only the properties dialog is opened, but the JS bookmarklet code also seems to be automatically executed along the way as an unwanted side-effect. This results in the opening of the JS shell in a new window every time the properties dialog is accessed.
- the location inputbox in the properties dialog cannot display the containing JS code correctly. Attempts to horizontally move through the location-box' content with either the arrow keys or the mouse temporarily result in a completely white location input-box (the text is still there though - rendering bug on itself?).

Unfortunately I am currently lacking the time to further isolate these newly arisen issues.
WFM on current trunk
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20081215
Minefield/3.2a1pre

feel free to reopen if you still see this.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.