Attachment icon in the Message list comes and goes for a message with no attachments

RESOLVED WORKSFORME

Status

--
minor
RESOLVED WORKSFORME
13 years ago
8 years ago

People

(Reporter: rhmzgx56, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(5 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: version 1.5 (20051201)

In my Local Folders Inbox (using Classic View) there are several messages listed. Many of these have attachments, and show the paperclip icon that indicates the presence of attachment(s).

It seems that the paperclip icon comes and goes for one of these messages, depending upon which other message is highlighted. If any of that message or the other three latest arrivals is selected, the paperclip icon vanishes. I will shortly be attaching JPEG files showing this.

Also, the last (latest) message in the list does not show a paperclip, even though the message does contain a graphic file attachment.

Reproducible: Always

Steps to Reproduce:
Well, with this particular mailbox state, the paperclip comes and goes with regularity. However, I have not noticed this problem before, so do not know how reproducible it is in the general case, nor do I know what triggers the situation.
(Reporter)

Comment 1

13 years ago
Created attachment 214185 [details]
Showing the attachment paperclip present on the 1:40 message.

Note the 1:40am message, how it shows a paperclip attachment present icon.
(Reporter)

Comment 2

13 years ago
Created attachment 214186 [details]
Showing the attachment paperclip absent on the 1:40 message.

Note the 1:40am message, how it shows no paperclip attachment present icon.

Comment 3

13 years ago
There is something odd going on there.  Not just the 1:40AM message, but also the last one in the 3:22PM batch from above -- that message clearly has an attachment (when selected) but the icon isn't shown.

Does the 1:40AM message actually have an attachment when you select it?

Is this for an IMAP or a POP account?

For POP, the first thing I would try is to delete the index file (Inbox.msf) 
and restart TB, see if the behavior continues.

Comment 4

13 years ago
When you download message headers, we look at the content type, and if it's multipart/mixed, we decide it has an attachment. When you read the message, we check if Mime found any actual non-v-card attachments, and if it didn't, we remove the paperclip icon. Does it sound like that's what's happening? The message has a paperclip when we download the headers, but it disappears when you read it? That would imply some problem loading the message, and not a problem with the .msf file. Does anything appear on the js console when you click on the problem message?
(Reporter)

Comment 5

13 years ago
Received a new message in that folder. Deleted new message after reading it. Now, unable to reproduce the phantom paperclip effect. Undo message deletion, still unable to reproduce.

Exited Thunderbird and re-started. Now, the 1:40 message paperclip remains solid, the 3/4 3:22pm paperclip vanishes when the 3/4 3:34pm message entry is selected, or any of the other three newer messages (1:40, 4:10, or 7:13).
(Reporter)

Comment 6

13 years ago
(In reply to comment #4)
The 1:40 message is multi-part, including some HTML and a GIF. It is currently behaving, showing the paperclip always. Now, the 4:10am message shows a paperclip sometimes and not others. The 4:10am message has no attachments and is not multi-part.

(In reply to commend #3)
I exited Thunderbird and renamed Inbox.msf to Inbox.msfsav, then started Thunderbird again. Going to the Local Folders Inbox, it took several seconds (which I assume to be re-creating the index). Now, the last 3:22pm message has the phantom paperclip.

Comment 7

13 years ago
I can confirm this problem with Thunderbird version 1.5 (20060313) on Linux (i686)

The Mail account is an IMAP account. The only extension installed is Enigmail.

There are 2 Messages with attachments, sent by the same person with the same Webmailer within 1 hour, each with a Content-Type of "multipart/mixed"
and a "Content-Type: application/octet-stream" attachment.

When Thunderbird is started, both messages correctly show the paperclip icon.
As long as *any* of the two messages is selected, *both* show the paperclip icon.
When any *other* message is selected, the paperclip on the *first* of the two vanishes, and only reappears if one of the two messages is selected again.

Comment 8

13 years ago
Created attachment 216016 [details]
message list after thunderbird startup

This shows the message list after thunderbird startup. The messages I'm talking about are the two at the top. Both show the paperclip.

Comment 9

13 years ago
Created attachment 216017 [details]
message list after selecting an unrelated message.

After selecting an older message, the paperclip on the 1st message vanishes.

Comment 10

13 years ago
Created attachment 216018 [details]
message list after selecting one of the two related messages.

After selecting the 2nd message, the paperclip on the 1st one reappears.

Comment 11

13 years ago
do these messages by any chance have the same message-id?

Comment 12

13 years ago
(In reply to comment #11)
> do these messages by any chance have the same message-id?

No, they have different IDs.
The Javascript Console shows 1 error, but I don't think it's related, since none of the messages contains HTML:

  Error: Unknown namespace prefix 'html'.  Ruleset ignored due to bad selector.
  Source File: chrome://messenger/skin/messageBody.css
  Line: 55

Comment 13

12 years ago
See bug 350984, which is similar.  The URL at that bug points to an AVI file showing the attachment icon blinking in and out as *other* messages are selected; very peculiar.

Comment 14

12 years ago
*** Bug 350984 has been marked as a duplicate of this bug. ***

Comment 15

12 years ago
Quoting some text from bug 350984:

===
To clarify: in my case this is an IMAP mailbox, and the message in question is
a plain text message, no attachments, no vcards.

Plus, this doesn't happen with my Thunderbird on Linux (today; this might be
irrelevant, but still...)

And it doesn't happen with that exact same message on Windows anymore either...
Can this only be applicable to the first few messages in a list?
===

BTW, I too have (and had back then) Enigmail installed.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 16

12 years ago
Bug 357251 has this symptom, and the affected message (which is attached to that bug: attachment 242745 [details]) is text/plain, not multipart of any flavor.  It is quoted-printable and Windows-1251 (Cyrillic); and it has this header:
  Content-class: urn:content-classes:message
I don't know if any of those factors make a difference.

Comment 17

12 years ago
I had this on Linux too. Plus, bug 357251 reports the same problem on Linux.
OS: Windows 2000 → All

Comment 18

12 years ago
BTW attachment 242745 [details] has an invalid Subject (not encoded properly), and an empty X-MS-Has-Attach:  header. This may or may not be related to the problem too...
QA Contact: front-end

Comment 19

12 years ago
And looking at the screenshots, it's evident that the user has Enigmail installed too. So far, all of the people who have confirmed this bug, had Enigmail extension installed. I suspect this might be its fault.

Comment 20

12 years ago
*** Bug 357251 has been marked as a duplicate of this bug. ***

Updated

12 years ago
Summary: Message List Attachment Icon Phantom → Attachment icon in the Message list comes and goes for a message with no attachments

Comment 21

12 years ago
It seems that it is fixed for me as of 1.5.0.8. Messages are getting correct icon when clicking on them for the first time and the icons stays there. Dunno for new messages, but found out a number of such a messages from the same recipient and all of them seems to get correct icon when clicking on them.
So, I suppose Comment #4  is correct with the rule that now it does save the state after the message was displayed.
Note: If this is the case and it will work same way (I'll check this recipient new messages) for new messages, I'd prefer for status to be updated on message download and not display (RFE).

Comment 22

12 years ago
(In reply to comment #21)
> It seems that it is fixed for me as of 1.5.0.8. Messages are getting correct
> icon when clicking on them for the first time and the icons stays there. Dunno
> for new messages, but found out a number of such a messages from the same
> recipient and all of them seems to get correct icon when clicking on them.
> So, I suppose Comment #4  is correct with the rule that now it does save the
> state after the message was displayed.

I don't think this bug is sender-dependant. I think it happens quite randomly, and rarely enough.

Comment 23

12 years ago
I suppose It may be dependant on mail agent/it's settings (style of mime composed).

Comment 24

12 years ago
I have recently spotted same behaviour in Thunderbird on Ubuntu. Again, I had Enigmail installed.

Patrick, would you have any comments on this?

Comment 25

12 years ago
Enigmail does not do anything on the message list or dbView, so I really don't have any idea why it happens.

Comment 26

12 years ago
Narrowing the problem down: the attachment icon comes and goes on an absolutely random message in the sense that message doesn't have to be any special BUT... Here's what I've just found out:

The attachment icon only comes and goes on a message that you FIRST click on after launching Thunderbird. I've just checked that with some messages. It's absolutely irrelevant IF the message has the attachment or no, or what mailer you use for it etc. It's simply enough for it to be first clicked on.

Furthermore, this problem only occurs when Enigmail extension is installed and turned on.

Patrick, or anyone, would you please check such scenario?..

Comment 27

11 years ago
Does everyone agree this is gone after 1.5.0.8 and thunderbird 2?
bug 335920 is possible duplicate.
Version: unspecified → 1.5
Assignee: mscott → nobody

Updated

10 years ago
Duplicate of this bug: 335920

Comment 29

8 years ago
I've never seen this and no one responded.
so => WFM
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.