Last Comment Bug 329546 - Separate out the view model from a nsNavHistoryResult
: Separate out the view model from a nsNavHistoryResult
Status: RESOLVED FIXED
: fixed1.8.1
Product: Firefox
Classification: Client Software
Component: Bookmarks & History (show other bugs)
: Trunk
: All All
: P1 normal (vote)
: Firefox 2 alpha2
Assigned To: Brett Wilson
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-06 14:11 PST by Brett Wilson
Modified: 2009-11-26 06:32 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Backend patch (161.85 KB, patch)
2006-03-15 09:26 PST, Brett Wilson
bugs: review+
Details | Diff | Review
Frontend patch (11.23 KB, patch)
2006-03-15 09:26 PST, Brett Wilson
bugs: review+
Details | Diff | Review
Build patch (2.94 KB, patch)
2006-03-15 09:35 PST, Brett Wilson
annie.sullivan: review+
Details | Diff | Review

Description Brett Wilson 2006-03-06 14:11:04 PST
Currently nsNavHistoryResult implements a treeview and notifies the associated tree of things being added, deleted, or changed. This kind of sucks because other non-tree uses (like the toolbar) don't know what's changed.

There should be an in-between view interface. One standard component would be a tree view that implements the current functionality. Other users such as the toolbar would implement their own.
Comment 1 Brett Wilson 2006-03-15 09:26:13 PST
Created attachment 215141 [details] [diff] [review]
Backend patch
Comment 2 Brett Wilson 2006-03-15 09:26:48 PST
Created attachment 215142 [details] [diff] [review]
Frontend patch
Comment 3 Brett Wilson 2006-03-15 09:35:54 PST
Created attachment 215144 [details] [diff] [review]
Build patch

Sorry, I forgot the browser/components/build stuff in the previous patches.
Comment 4 Annie Sullivan 2006-03-16 16:08:33 PST
Comment on attachment 215142 [details] [diff] [review]
Frontend patch

Weren't there supposed to be changes to toolbar.xml as well, to move it from always rebuilding when its observer gets a notification to using the view to update its UI?
Comment 5 Brett Wilson 2006-03-22 13:44:41 PST
(In reply to comment #4)
> (From update of attachment 215142 [details] [diff] [review] [edit])
> Weren't there supposed to be changes to toolbar.xml as well, to move it from
> always rebuilding when its observer gets a notification to using the view to
> update its UI?

You or I can do that separately. The toolbar will keep working the way it is in the meantime.

Comment 6 Ben Goodger (use ben at mozilla dot org for email) 2006-03-22 14:46:38 PST
Comment on attachment 215141 [details] [diff] [review]
Backend patch

r=ben@mozilla.org
Comment 7 Ben Goodger (use ben at mozilla dot org for email) 2006-03-22 14:47:07 PST
Comment on attachment 215142 [details] [diff] [review]
Frontend patch

r=ben@mozilla.org
Comment 8 Brett Wilson 2006-03-22 16:57:16 PST
On branch and trunk.
Comment 9 Joe Hughes 2006-03-22 22:16:37 PST
Looks like failing to change the getResult() call to a getResultView() in tree.xml:553 during this change broke the Add Bookmark dialog.
Comment 10 Joe Hughes 2006-03-22 22:31:35 PST
OK, I put a quick fix for the breakage mentioned above into my patch for bug 330192, which I just landed on branch & trunk.
Comment 11 Gervase Markham [:gerv] 2009-11-26 06:32:41 PST
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv

Note You need to log in before you can comment on or make changes to this bug.